Recent Files in Windows 10 not populating when opening/saving in Office and OneDrive...

Jay Smith 0 Reputation points

Hi there, I have a rather unusual problem with a client's PC.

It seems that whenever a file in their OneDrive folder is opened and they Save a Copy to another location in their OneDrive, it doesn't show in Recent Files in Windows 10 like it normally should. The same thing also happens when a file is opened directly in Office such as Word or Excel.

However, it does populate and show in Recent Files when a file is saved to a local folder NOT backed up by OneDrive or if OneDrive is uninstalled completely.

Their Windows 10 is at 22H2, their Office and OneDrive have been updated to the latest version.
Show recently opened items in Jump Lists IS ENABLED.
Recent Files in Quick Access is enabled. Show recently used files and frequently used files in Quick Access is also enabled.

I have also run system file check and DISM image repair to no avail.

If someone could provide suggestions or assistance, that would be appreciated.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,576 questions
A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.
1,289 questions
A Microsoft file hosting and synchronization service.
799 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Emily Hua-MSFT 27,526 Reputation points

    Hi @Jay Smith

    From OneDrive's point of view, please ensure Files On-Demand is not enabled in OneDrive client.

    If you need this feature, please also try to mark files as "Always keep on this device".

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments