Change Azure VM Time

Alex Toniati 121 Reputation points
2023-03-08T12:51:51.6766667+00:00

Hi all,

I need to change the timezone for all my azure VMs, but I do not know the right way for that.

I have an Windows AD in the Azure and many others Windows Server AVMs inside this domain.

I ran the command w32tm /dumpreg /subkey:Parameters | findstr /i "type" in my domain controller and in my other windows servers azure vms. The output for DC was Value Data = NTP and for the other one was Value Data = NT5DS

Then ran the command w32tm /query /source for both servers, and for both the output was the same: VM IC Time Synchronization Provider

So, how can I change the time for whole environment, just change in DC and all the clients in the domain will update? I need to change inside the Azure Portal and if so, how do it? Etc.

Thanks in advance

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,092 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Alex Toniati 121 Reputation points
    2023-03-08T14:01:57.8866667+00:00

    I just run the command Set-TimeZone -Id " E. Australia Standard Time" in my domain controller (hosted in Azure) and the time was update successfully.

    But my other server in this domain dont get automatic time update, they dont have any GPO configuration to force anything and I think they should be synced with domain controller once the Value Data = NT5DS.

    For clarification, when I run the command net time in one of this server, I get an weird response of Current Time and Local Time from my DC, and they are different from each other, as you can see in attached image.

    There is any other step to make this changes to sync to all other domain joined devices?

    Thanks,


  2. Alex Toniati 121 Reputation points
    2023-03-08T20:27:35.3766667+00:00

    Bingo, solved!

    0 comments No comments

  3. kobulloc-MSFT 23,336 Reputation points Microsoft Employee
    2023-03-10T22:57:52.8566667+00:00

    Hello, @Alex Toniati !

    Thank you very much for the update! To confirm, you ran the command Set-TimeZone -Id " E. Australia Standard Time" in your domain controller (hosted in Azure) and the time was updated? It sounds like the other server in the domain had a delay before it was automatically updated or did they need Value Data = NT5DS?

    0 comments No comments