certsrv access not working with Edge

Carl Burch 216 Reputation points
2023-03-09T02:41:30.9333333+00:00

PKI setup on server 2019 joined to domain as member server.

Trying to use MS Edge to access our local PKI. URL structure is https://servername.domain.local/certsrv

This works perfectly fine with IE. But with Edge, while the initial page loads just fine, I click on "Request a Certificate", I'm only offered the option for a Base-64 encoded request file. I'm not seeing the options where I can create and submit a request.

I figure it's something to do with settings in edge, yet have no idea where to start. Thanks for any help.

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,430 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Carl Burch 216 Reputation points
    2023-03-09T16:46:05.46+00:00

    Seems I've found something that works, if someone can mark this as answered, as I don't believe I am able to do that on my own posts. The below worked on a Windows 10 setup. Don't know about Windows 11.

    • right-click the start button and select Run.
    • Enter CONTROL and press enter to open the control panel.
    • If control panel is not in icon view, switch from Category to Small Icons.
    • Open the Internet Options applet and select the Security tab.
    • Select whatever zone your Certificate Authority computer is in. For me, the CA is a domain member, but I'm attempting to access from the local network using a computer that is not a domain member. So I select Local Intranet.
    • Click the Sites button to open the Local intranet pop-up.

    = On the pop-up click the Advance button.

    • Enter the full URL to your CA. For example, https://myca.mydomain.local/certsrv
    • Click the Add button to add this website to the Websites list.
    • Click the Close button, followed by the OK button, then click OK again to close the Internet properties dialog.
    • Start Microsoft Edge (not Internet Explorer) and enter the full URL to the CA website and press enter. If prompted for login credentials (expected) enter your administrator credentials for the website and log on to the home page of the website. (domain credentials if the CA is a domain member.)
    • After you log in, you'll see an Internet Explorer icon in the upper right of your browser. If you float your mouse over it, the pop-out will read, "Reload tab in Internet Explorer Mode". Click that icon to reload the webpage in IE mode.
    • If prompted to log in again, do so using the same credentials as before.
    • You see a pop-up titled "This page is open in Internet Explorer Mode".
    • Turn on the option for "Open this page in Internet Explorer mode next time" then click Done.
    • Close and re-open Microsoft Edge. Connect to your CA website and all should work now. If you are still prompted for login credentials and should not be, that's usually because your have the CA website in the wrong security zone in Control Panel/Internet Options.
    1 person found this answer helpful.