Could not find stored procedure 'master.sys.sp_executesql' error after running sp_vupgrade_replication

ENGIN SENOL 1 Reputation point
2023-03-09T14:34:06.0733333+00:00

Hello,

We upgraded SQL 2012 to 2016, upgrade completed with below replication error. After the upgrade, we applied all the patches/updates for SQL Server. When we try to repair the SQL Server, still getting same error on the repair.

Error installing SQL Server Database Engine Services Instance Features

There was an error executing the Replication upgrade scripts. See the SQL Server error log for details.

Error code: 0x851F947E

I tried to run sp_vupgrade_replication, however it gives "Msg 2812, Level 16, State 62, Line 1 Could not find stored procedure 'master.sys.sp_executesql'." error at the end.

Thanks all

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,654 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. ENGIN SENOL 1 Reputation point
    2023-03-09T15:39:54.0133333+00:00

    I found the issue. there was a disabled subscription from offline server. Deleted that subscription and problem is fixed.

    0 comments No comments