how to fix not enabling multiple user session in windows 10 pro 22h2 version

Janith Sahasra 6 Reputation points
2023-03-15T08:37:25.91+00:00

in my sever i've installed the windows 10 pro 22h2 version and when i try to connect to same user using RDP it's not allowed me to having 2 sessions i've already tried it changing fsinglesessionper user value to 0 and it's not working but it's working with other windows server versions is this beacuse of new update or anythis else? is there way to slove this?

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,586 questions
Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,726 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,229 questions
Windows 10 Compatibility
Windows 10 Compatibility
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Compatibility: The extent to which hardware or software adheres to an accepted standard.
454 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 43,926 Reputation points
    2023-03-16T15:09:37.2433333+00:00

    Hi,

    I'd be happy to help you out with your question. Sorry for the inconvenience caused.

    Windows 10 Pro 22H2 does not support multiple user sessions natively. However, Windows 10 Enterprise multi-session and Azure Virtual Desktop allow multiple concurrent user sessions. If you have Windows 10 Pro, you can use Group Policy to trigger auto-enrollment to MDM for Active Directory domain-joined devices. You can also configure a kiosk device running Windows 10 so that users can only run specific apps.

    As Enabling multiple user sessions on Windows 10 Pro 22H2 without using third-party tools is not officially supported by Microsoft. However, there are some workarounds that you can try, which involve modifying the Windows registry. Here are the steps:

    1. Press Win + R keys to open the Run dialog box, type "regedit" and hit Enter to open the Registry Editor.
    2. Navigate to the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
    3. Find the "fSingleSessionPerUser" value and double-click on it to modify.
    4. Change the value data from "1" to "0" and click OK.
    5. Navigate to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services
    6. Create a new DWORD value called "AllowMultipleTSSessions" and set its value data to "1".
    7. Restart your computer.

    After these steps, you should be able to connect to the same user account via Remote Desktop Connection from different machines, or from the same machine using different user accounts. However, please note that modifying the registry can have unintended consequences and may cause system instability. Therefore, it's recommended to create a backup of your registry before making any changes, and use this workaround at your own risk.

    For more Information please refer to following resources :-

    1. Windows 10 Enterprise multi-session FAQ - https://learn.microsoft.com/azure/virtual-desktop/windows-10-multisession-faq
    2. Using Azure Virtual Desktop multi-session with Microsoft Intune - https://learn.microsoft.com/mem/intune/fundamentals/azure-virtual-desktop-multi-session
    3. Enroll a Windows 10 device automatically using Group Policy - https://learn.microsoft.com/windows/client-management/enroll-a-windows-10-device-automatically-using-group-policy
    4. Set up a multi-app kiosk on Windows 10 - https://learn.microsoft.com/windows/configuration/lock-down-windows-10-to-specific-apps
    5. What's new in MDM enrollment and management - https://learn.microsoft.com/windows/client-management/new-in-windows-mdm-enrollment-management

    If you have any other questions or need assistance with anything, please don't hesitate to let me know. I'm here to help.

    If the reply was helpful, please don’t forget to upvote or accept as answer, thank you.

    0 comments No comments