Azure Arc - 'NoRegisteredProviderFound' when attempting to access Windows Admin Center

Chris 5 Reputation points
2023-03-15T19:36:12.4533333+00:00

I've had Azure Arc implemented in my environment for a while now - primarily used for Defender for Cloud. I have wanted to strengthen the capabilities of our Arc-enabled servers by enabling Windows Admin Center.

I onboarded a few with the AdminCenter extension yesterday (UK South), and all worked fine - I was able to connect in without an issue. However, when I try today - I get the message: 'No registered resource provider found for location 'uksouth' and API version '2021-05-20' for type 'endpoints'. The supported api-versions are '2021-10-06-preview, 2022-05-01-preview'.

I can confirm the resource providers Microsoft.HybridCompute/GuestConfiguration/HybridConnectivity are registered against the linked subscription which contains the resource group, I've tried unregistering and registering again.

Extensions running: AdminCenter (0.0.0.228), MicrosoftMonitoringAgent (1.0.18067.0), MDE.Windows (1.0.8.3), WindowsPatchExtension (1.5.59), AzureMonitorWindowsAgent (1.13.0.0). Uninstalled/Installed and Offboarded/Onboarded both server(s) and extensions.

I've reviewed and packet captured firewall logs and can see no packet drops. The Arc-enabled servers are reporting back to Azure fine. Reverse Proxy is enabled too for the port 6516 with the Azure Connected Machine Agent.

Anyone seen this behaviour before? Doesn't seem to be much info online, thanks.

Azure Arc
Azure Arc
A Microsoft cloud service that enables deployment of Azure services across hybrid and multicloud environments.
318 questions
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,091 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 43,926 Reputation points
    2023-03-16T14:55:51.1633333+00:00

    Hello there,

    If Azure doesn't automatically register a resource provider, you can do a manual registration.

    This article describes resource provider registration errors that occur when you use a resource provider that you haven't already used in your Azure subscription. The errors are displayed when you deploy resources with a Bicep file or Azure Resource Manager template (ARM template).

    https://learn.microsoft.com/en-us/azure/azure-resource-manager/troubleshooting/error-register-resource-provider?tabs=azure-cli

    Hope this resolves your Query !!

    --If the reply is helpful, please Upvote and Accept it as an answer--

    0 comments No comments