How to whitelist/allow file types for download in Edge (and block anything else)?

d d 0 Reputation points
2023-03-17T16:13:36.11+00:00

Is there a way (using Windows 11 Pro 64 and Edge, local computer) to whitelist/allow file types (e.g. .pdf) for downloading and block anything else?

I already found the possibility to set DownloadRestrictions, but with this setting I can't specify the file types I want to block. I can only block any downloads (option 3) or malicious downloads (option 1) or potentially dangerous or unwanted downloads (option 2).

And I found the possibility to set ExemptFileTypeDownloadWarnings, but this just shows or blocks the warnings for specific file types (and/or domains) which can be ignored by the user.

So can anyone help me to whitelist file types for download and block anything else? Is there a way via GPO or whatever?

thanks

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,108 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Deepak-MSFT 2,191 Reputation points Microsoft Vendor
    2023-03-20T09:36:09.65+00:00

    Hi @d d,

    I research about the GPO and other settings to block / whitelist specific extension type files.

    At present, GPO available to only put the Download restrictions. Currently, there is no way to block / whitelist specific extension type files from downloading.

    You could press ALT+SHIFT+I key in the Edge browser and provide your feedback to Microsoft regarding the requested feature.

    Best Regards,

    Deepak


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. d d 0 Reputation points
    2023-03-21T20:03:36.05+00:00

    that's quite a little sad and I did not expect that answer, but thanks anyway

    0 comments No comments