Unable to copy/move/transfer vhdx file (Hyper-v)

Vidar 1 Reputation point

(Windows 10 Pro)

What am I trying to do?

I have a 1TB NVME card which stores all my virtual machines for Hyper-V - nothing else. I am running out of disk space and would like to transfer existing VMs to a new 2TB NVME card. The VM's won't copy - something to do with the actual vhdx file that it doesn't like - see below for more details:


I am unable to copy and paste a vhdx file from my current drive (1TB Samsung NVME) to my new drive (2TB Samsung NVME).

I have tried:

  • Copy/Paste Windows explorer
  • Robobopy
  • 'Move' command in Hyper-V Manager
  • 'Export' command in Hyper-V Manager
  • Powershell (administrator) use Export-VM command
  • NVME clone using a piece of hardware that should clone NVME cards - it can do this without being connected to a PC - as it has its own power supply. Can be bought off Amazon fairly cheap.

The error message I get when trying to export my VM (called PythonDev) to my bigger drive is:

[enter image description here


If I try and copy and paste I get the following error (but is still the same underlying problem I think). I have narrowed it down to actually copy the vhdx file - nothing I can do will allow me to copy that file:

[enter image description here


Here is the Powershell error:

[enter image description here


Can anyone help?

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
7,568 questions
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
442 questions
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,071 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 27,116 Reputation points


    Thank you for your question and reaching out. I can understand you are having query\issues related to Hyper-V vhdx copy to different drive.

    1. Please check if the Hyper V snapshots avhdx files has the good link with the parent disk.
    2. Try to Remove all checkpoints of that VM.
    3. Disable any Antivirus program or Windows firewall you may have for temporary purpose.
    4. Boot your Server in to Safe mode and try to copy .vhdx file.
    5. Perform full check\scan disk of the disk using

    chkdsk /f /r <DriveLetter>

    --If the reply is helpful, please Upvote and Accept as answer--