Working Applications fail to install in SCCM Task sequence

Chauhan, Aniket 10 Reputation points
2023-03-30T14:55:15.4866667+00:00

Hi everyone,

We have an issue with working applications(O365 apps) do not install through the task sequence, all the packages install through task sequence but applications explicitly fail with the error message shown in the image below.

After reviewing logs, the only thing i could find is the error message stating the download failed. But when we deploy the applications directly outside of the task sequence, they install fine and working. The application is functioning so there is no issue with the application itself. Is this a SCCM bug? I have tried adding google chrome as an application as well just to try and add a smaller size app, and even that app gets the same error message as below. How can i get my applications to install during task sequence through SCCM?
User's image

Microsoft Configuration Manager Application
Microsoft Configuration Manager Application
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Application: A computer program designed to carry out a specific task other than one relating to the operation of the computer itself, typically to be used by end users.
460 questions
Microsoft Configuration Manager
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Chauhan, Aniket 10 Reputation points
    2023-03-31T16:21:45.53+00:00

    Hi Cherry,

    Thank you for the suggestion to integrate into the boot image for O365 apps,

    This is not working for any application through task sequence, we have tried, google chrome, adobe acrobat, etc. apps and they do not install through task sequence, only packages work.

    That solution unfortunately does not work out for us as it requires a deployment tool which we currently do not have and we also do not want to experiment with the boot image.

    I am wondering why the application function for task sequence is not working when in the application model, there is an option to check mark "Allow this app to install from task sequence", this tells me that the application deployment should work from task sequence, but it is just failing, all packages install fine, can you please give us a solution to make this work.

    1 person found this answer helpful.

  2. CherryZhang-MSFT 6,481 Reputation points
    2023-03-31T05:18:14.64+00:00

    Hi @Chauhan, Aniket

    1, Did only O365 apps fail to install in the task sequence? If so, I have met a lot of people who had the same problem as you. It is recommended that you could integrate the O365 apps into the image and then deploy it.

    2, We will try to feedback it to the product team and recommend you submit your problem to the feedback website at the same time. We take the customer experience very seriously and thank you for your understanding.

    Thank you for your time and patience!

    Best regards,
    Cherry


     

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  3. Ronny Van den Broeck 0 Reputation points
    2023-10-24T06:16:31.5066667+00:00

    The problem at hand is the size of the Office 365 download.

    Depending on how you configure your Office 365 Client Management, the size can go over 5 Gb, which is the sccm client cache limit during OS deployment.

    Integrate a powershell script in a task sequence step before your Office 365 deployment to change the size of the sccm client cache, and the download will work.

    Here is an example of the powershell script you can use:

    $Cache = Get-WmiObject -Namespace 'ROOT\CCM\SoftMgmtAgent' -Class CacheConfig

    $Cache.Size = '25600'

    $Cache.Put()

    Restart-Service -Name CcmExec

    0 comments No comments