Disable Soft delete recovery service vault

Danilo Ortiz 1 Reputation point
2023-03-31T21:07:00.3633333+00:00

When I try to disable the soft delete for a recovery service vault to delete it I face the below error message.

I'm using an Azure Account with Owner Role over the Resource Group where I did put the RSV.

User's image

When I tried to disable the soft delete from RSV overview I face the below error:

User's image

Waiting for your reply soon!!!

Azure Backup
Azure Backup
An Azure backup service that provides built-in management at scale.
1,141 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Tech-Hyd-1989 5,746 Reputation points
    2023-04-02T19:17:14.8966667+00:00

    Hello @Danilo Ortiz

    In your case it appears to be an issue within the azure side SDK causing the error "input provided for the call is invalid". My recommendation is to try from command line method like azure PowerShell as a quick workaround to get you unblocked from this situation.

    Follow this link from Microsoft azure backup documentation for help with disabling soft-delete from vault using Azure PowerShell: https://learn.microsoft.com/en-us/azure/backup/backup-azure-security-feature-cloud#disabling-soft-delete-using-azure-powershell

    Set-AzRecoveryServicesVaultProperty -VaultId $myVaultID -SoftDeleteFeatureState Disable StorageModelType : StorageType : StorageTypeState : EnhancedSecurityState : Enabled SoftDeleteFeatureState : Disabled

    Note: If items were deleted before soft-delete was disabled, then they'll be in a soft-deleted state for 14days. To immediately delete them, the deletion operation needs to reversed and then performed again.

    If you still happen to see the same error, I would recommend logging a support case with Azure backup team for diagnosing this issue.

    If this does answer your question, please accept it as the answer as a token of appreciation.

    0 comments No comments

  2. Danilo Ortiz 1 Reputation point
    2023-04-03T22:00:46.19+00:00

    After run the PS command suggested (Set-AzRecoveryServicesVaultProperty -VaultId $rsv1.id -SoftDeleteFeatureState Disable) I can disable the soft delete for cloud (see the below image) User's image

    Now when I try to disable the Soft delete for hybrid workloads running the below command: Set-AzRecoveryServicesVaultProperty -VaultId $rsv1.Id -DisableHybridBackupSecurityFeature $true I face the below error: User's image


  3. SadiqhAhmed-MSFT 38,891 Reputation points Microsoft Employee
    2023-05-04T11:28:23.5433333+00:00

    "Sharing with broader community"

    The issue was classified as an Azure Bug and it was fixed by Azure production team.

    0 comments No comments