AMD integrated graphics on a laptop was not identified by the app when running desktop envrionment on wslg.

Mai Zhou 0 Reputation points
2023-04-01T00:28:41.73+00:00

Gpu driver, including vesa, mesa, xf86-video-amdgpu and ATI were all installed:

$ pacman -Ss xf86-video
extra/xf86-video-amdgpu 23.0.0-1 (xorg-drivers) [installed]
    X.org amdgpu video driver
extra/xf86-video-ati 1:19.1.0.r15.g7a6a34af-1 (xorg-drivers) [installed]
    X.org ati video driver
extra/xf86-video-dummy 0.4.0-1 (xorg-drivers)
    X.org dummy video driver
extra/xf86-video-fbdev 0.5.0-3 (xorg-drivers) [installed]
    X.org framebuffer video driver
extra/xf86-video-intel 1:2.99.917+923+gb74b67f0-1 (xorg-drivers)
    X.org Intel i810/i830/i915/945G/G965+ video drivers
extra/xf86-video-nouveau 1.0.17-2 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards
extra/xf86-video-openchrome 0.6.0.r798.g0c75274-1 (xorg-drivers)
    X.Org Openchrome drivers
extra/xf86-video-sisusb 0.9.7-4
    X.org SiS USB video driver
extra/xf86-video-vesa 2.6.0-1 (xorg-drivers xorg) [installed]
    X.org vesa video driver
extra/xf86-video-vmware 13.4.0-1 (xorg-drivers)
    X.org vmware video driver
extra/xf86-video-voodoo 1.2.6-1 (xorg-drivers)
    X.org 3dfx Voodoo1/Voodoo2 2D video driver
community/xf86-video-qxl 0.1.5.r23.g52e9752-2 (xorg-drivers)
    Xorg X11 qxl video driver

But:

$ lspci | grep -e VGA -e 3D
ecb9:00:00.0 3D controller: Microsoft Corporation Basic Render Driver

And then I start the desktop environment(KDE-Plasma) directly with the commend below:

$ sudo kwin_x11 --replace &
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
kwin_platform_x11_standalone: Bogus refresh rate 0
**kwin_xkbcommon: XKB: inet:323:58: unrecognized keysym "XF86EmojiPicker"
kwin_xkbcommon: XKB: inet:324:58: unrecognized keysym "XF86Dictate"**
Couldn't start kglobalaccel from org.kde.kglobalaccel.service: QDBusError("org.freedesktop.DBus.Error.Disconnected", "Not connected to D-Bus server")
kwin_core: Parse error in tiles configuration for monitor "3e6a13d3-7d29-5922-82c3-84e8bdf10429" : "illegal value" Creating default setup
OpenGL vendor string:                   Microsoft Corporation
OpenGL renderer string:                 D3D12 (AMD Radeon(TM) Graphics)
OpenGL version string:                  4.2 (Compatibility Profile) Mesa 23.0.1
OpenGL shading language version string: 4.20
Driver:                                 Unknown
GPU class:                              Unknown
OpenGL version:                         4.2
GLSL version:                           4.20
Mesa version:                           23.0.1
Linux kernel version:                   5.15.90
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
kwin_platform_x11_standalone: glSwapInterval is unsupported

Note that:

Driver: Unknown GPU class: Unknown

CPU: AMD Ryzen7 5800U with Radeon Graphics GPU: The AMD Radeon(TM) Graphics

What should I do now to run the desktop enviroment normally on wslg?

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,380 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. John Smith 0 Reputation points
    2023-04-03T12:29:34.8633333+00:00

    Wrong thread

    0 comments No comments

  2. Limitless Technology 43,996 Reputation points
    2023-04-03T12:32:00.05+00:00

    Hello there,

    You can force an app to use the dedicated GPU. You must be running Windows 10 1809 or later for this to work.

    -Open the Settings app and go to the System group of settings.

    -Select the Display tab and scroll down.

    -Click the ‘Graphic Settings‘ option.

    -On the Graphics Settings screen, open the ‘Choose an app to set preference‘ dropdown.

    -Select the type of app you want to set the GPU use for; Classic app for desktop apps, and Universal app for UWP or Store apps.

    -Once selected, click the Browse button and select the app. Click the ‘Options‘ button under the app once it has been added.

    -In the window that opens, select ‘High Performance‘ and click ‘Save‘.

    Hope this resolves your Query !!

    --If the reply is helpful, please Upvote and Accept it as an answer--

    0 comments No comments