Security Update for SQL Server 2019 RTM GDR (KB5021125) Incorrectly Detects a Cluster

Kenneth Demming 5 Reputation points
2023-04-02T01:38:40.6733333+00:00

Security Update for SQL Server 2019 RTM GDR (KB5021125) Fails with the message below. The issue I am having is my PC is not part of any cluster nor has it ever been, nor have I installed it as a cluster. Not sure where this is coming from, or how to correct it. Any assistance would be appreciated.

User's image

Here is my Discovery Report

User's image

Attempting to run Repair yields the same result.

User's image

I have tried to uninstall it as follows:

  1. Remove all SQL Server components from 'Programs and Features'
  2. Backup the registry
  3. Delete the following keys in regedit:
    --HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server
    --HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer
  4. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall and delete all the sub-keys referencing SQL Server
  5. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services and delete all the keys referencing SQL Server
  6. Reboot the machine

After the installation, the issue is the same.

Thank you in advance for reading this post, and any assistance you can give would be appreciated. Google searches have yielded nothing!

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,914 questions
{count} vote

2 answers

Sort by: Most helpful
  1. Rahul Randive 8,751 Reputation points Microsoft Employee
    2023-04-02T02:43:43.3966667+00:00

    Thanks for your question.

    Kindly refer to the blog below for information regarding the error you are currently experiencing, as well as potential workarounds to resolve it

    https://blog.sqlauthority.com/2018/02/17/sql-server-patch-rule-failure-not-clustered-cluster-service-online/

    Please feel free to contact us in case if this does not helps you.

    Thanks you.

    0 comments No comments

  2. Kenneth Demming 5 Reputation points
    2023-04-06T16:09:36.36+00:00

    Found this and it worked. Hi, There might be some WMI issue in your system. Please try to run below commands: cd \windows\system32\wbem
    net stop winmgmt
    rename Repository Repository.old
    net start winmgmt If issue persists, then please run:
    cd \windows\system32\wbem
    for /f %s in ('dir /b *.mof *.mfl') do mofcomp %s If this doesn't work please let me know Thanks, Credit goes to
    Eleven Yu (Shanghai Wicresoft Co,.Ltd.)
    • Here is the directory of Reposoitory.old and the new repository after the fix

    User's image

    User's image

    .

    0 comments No comments