Surface Go 3 - PXE Boot

Chèvre, Lorin 20 Reputation points
2023-04-03T14:56:25.1033333+00:00

Hello,

I am trying to deploy Surface Go 3 using a PXE server (Windows Server with MDT and WDS services) but cannot boot to the server. I tried :

  • Several USB-C --> Ethernet network adapters
  • Disabling Secure Boot
  • Check the date and time on the BIOS.

I'm out of ideas. Thank you in advance for your help.

Best regards,

Lorin

Microsoft Deployment Toolkit
Microsoft Deployment Toolkit
A collection of Microsoft tools and documentation for automating desktop and server deployment. Previously known as Microsoft Solution Accelerator for Business Desktop Deployment (BDD).
841 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. AllenLiu-MSFT 41,376 Reputation points Microsoft Vendor
    2023-04-04T02:03:09.7433333+00:00

    Hi, @Chèvre, Lorin Thank you for posting in Microsoft Q&A forum. You may try the following steps:

    1. Press the volume-up and power buttons on the Surface Laptop to enter the Unified Extensible Firmware Interface (UEFI) settings.
    2. Select Configure boot device order.
    3. Select the PXE Network, and then swipe to the left.
    4. You should receive the "Boot this device immediately" message. Click OK to exit and perform the PXE Network boot. For more details: https://support.microsoft.com/en-au/topic/pxe-boot-fails-on-a-surface-laptop-42adf628-487c-6cfc-13bf-b4ff238f5a84

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Add comment".