Error "the credentials supplied are not sufficient"

apzmslr34 20 Reputation points
2023-04-05T10:02:36.5766667+00:00

I am having issues with installing printer from printserver on local workstations (WORKGROUP, not domained). Windows 10 Machines seem to be working fine 99% of times
Windows 11 Machines seem not to be working 99% of times (One machine works fine, always had Win11 on it)

  1. Added a Registry Key via .reg File as a workaround to Error 0x0000011b
  2. Connecting printer via .bat script (\%servername%%printername%)
  3. Credentials box pops up and asks for permitted account to be typed in (none works, not even the domain admin)
  4. Error message: "Credentials Supplied Are Not Sufficient"

It only happens to Windows 11 machines, they seem to be handling local accounts differently in comparison to Windows 10 machines. I have tried different approaches and documented all of them, the basics:

  • Windows Firewall doesn't seem to be a problem, when turned off completely, it still doesn't work.
  • Point And Print Group Policies can't be edited since the machines don't allow you to open gpedit.msc
  • local Windows Credentials have all been deleted, it still doesn't work
  • the account typed into the credentials box works fine with Windows 10 machines (therefore has got permissions) and one Windows 11 machine
  • All machines are in the same subnet (network is not the issue)

Does anyone know the answer to this issue? Thanks in advance! Cheers
Lukas

Windows Server Printing
Windows Server Printing
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Printing: Printer centralized deployment and management, scan and fax resources management, and document services
648 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,441 questions
{count} votes

2 answers

Sort by: Most helpful
  1. apzmslr34 20 Reputation points
    2023-05-08T07:31:03.1+00:00

    Solution:

    As noted in reference https://learn.microsoft.com/en-us/answers/questions/1168568/error-credentials-supplied-are-not-sufficient-when (Don Baker comment), the solution is to add the credential in the windows credentials first, then add the printer. That way it doesn't prompt you to log in with said credentials, because that doesn't work on Windows 11.

    For some reason, local users in Win11 are handled differently to Win10 and the prompt can't be properly save your credentials to the windows credentials box. Instead, you just save the credential for that particular resource (in my case a printer on a printserver) and add the printer in a step aftwerwards.

    1. open Control Panel > User Accounts > Windows Credentials. Select Windows Credentials, then select Add Windows Credential.
    2. Fill out the fields (server name, user name, password) and click OK.
    3. Add printer, if printer is on said printserver you just saved a credential for, it automatically connects with it - no prompts appearing.
    3 people found this answer helpful.

  2. Limitless Technology 44,011 Reputation points
    2023-04-06T09:18:02.42+00:00

    Hello Thank you for your question and reaching out. I can understand you are having query\issues related to Printers can not be added. On Print server -> File-> Add/Remove Snap-in. Add Print Management. Select localhost. Select the print server. Right click-Properties -> Security. Now, Please give domain users and local users permissions to Print, Manage Printers, etc. Reference: https://learn.microsoft.com/en-us/answers/questions/1168568/error-credentials-supplied-are-not-sufficient-when --If the reply is helpful, please Upvote and Accept as answer--