Company portal on Oneplus Nord 2T 5G

Martin 0 Reputation points
2023-04-06T07:56:32.73+00:00

Hi, I can install Company portal on the phone (OnePlus Nord 2T 5G), but in step 3 of the installation, when checking for/the password, the steps fails. I will be asked to update the password, to contain 6 digits (it already does). Then I chose to update the password, a short pop up says "You are now using your personal profile", and then I can change my password. I can change it a 100 times times, company portal won¨t accept it. My guess is that the little pop up, alarms me that I'm using my personal profile, not the company profile, to change the password. And then, the password is never changed in the company profile. I have tried reinstalling the app, removing the company profile, and from OnePlus "support" I got this, nothing helped. settings >> security >> installation sources// trusted agents or apps >> allow company portal access.
settings >> security >> device admin apps >> allow admin access to Company portal.
settings >> security >> credential storage//Encryption and credentials >> trusted certificates// Trusted credentials >> allow Company portal credentials. Anyone got this to work ? OnePlus Nord 2T 5G Android 13 OxygenOS 13 Build CPH1299-11-C-24 Security patch: 5th of February 2023

Microsoft Intune
Microsoft Intune
A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.
4,451 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Crystal-MSFT 43,996 Reputation points Microsoft Vendor
    2023-04-07T01:40:13.7966667+00:00

    @Martin, Thanks for posting in Q&A. From your description, I know the device password already contain 6 digits. But it is failed. Based on my research,

    On Android 12 and later, if the Required password type setting is changed from the Device default value in a policy, then Newly enrolled Android Enterprise 12+ devices will automatically use the Password complexity setting with the High complexity.

    Here, we suggest create a new policy for Android Enterprise 12+ devices and configure the Password complexity setting to see if the result will be different.

    https://learn.microsoft.com/en-us/mem/intune/protect/compliance-policy-create-android-for-work#android-12-and-later---for-personally-owned-work-profile

    If there's any update, feel free to let us know.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.