Connection failed (no connection to the remote host)

peisk 5 Reputation points
2023-04-10T02:57:40.6733333+00:00

ConnectionFailure Encountered error. Error details: Connection failed (no connection to the remote host). Internal error: 1. Error details: Failed with error: WS_OPEN_ERROR_UNDERLYING_IO_OPEN_FAILED wss://eastasia.stt.speech.microsoft.com/speech/recognition/conversation/cognitiveservices/v1?language=zh-CN&postprocessing=TrueText&profanity=masked&stableIntermediateThreshold=3 X-ConnectionId: 322a3eb39a6a494592105270ecc6d045 SessionId: 322a3eb39a6a494592105270ecc6d045 Session stopped.

Azure AI Speech
Azure AI Speech
An Azure service that integrates speech processing into apps and services.
1,435 questions
{count} vote

3 answers

Sort by: Most helpful
  1. romungi-MSFT 42,756 Reputation points Microsoft Employee
    2023-04-10T12:35:59.7066667+00:00

    @peisk Adding reference to the GH issue that you already raised on the SDK repo.

    Based on the error it seems like a connection issue, has there been any change in your resource network settings or your network with a proxy setup? If Yes, did you try to use any other resource which does not have restrictions on its networking settings or run this sample on a different machine connected to a different network?

    If this answers your query, do click Accept Answer and Yes for was this answer helpful. And, if you have any further query do let us know.

    0 comments No comments

  2. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more

  3. zhou xing 0 Reputation points
    2024-03-13T06:55:46.3866667+00:00

    if you get this problem on macOS, you should go to your xx.entitlements file, then make "Access User Selected Files (Read Only)" to NO and "App Sandbox" to NO. i solved the problem in this way.

    0 comments No comments