/PrepareSchema error - [REQUIRED] A previous version of Exchange Server is already installed on this computer. Run Exchange Server 2019 Setup from a different computer or remove the previous version of Exchange Server.

Raphael Tremblay 0 Reputation points
2023-04-10T15:08:12.9833333+00:00

Hello- Trying to Setup.exe /IAcceptExchangeServerLicenseTerms_DiagnosticDataON /PrepareSchema for Exchange 2019 CU12 on a W2012R2 Exchange 2013 server. When checking the pre-requisites, throws the following error: Failed [Rule:ExchangeAlreadyInstalled] [Message:A previous version of Exchange Server is already installed on this computer. Run Exchange Server 2019 Setup from a different computer or remove the previous version of Exchange Server.] [04/08/2023 13:49:07.0334] [1] [REQUIRED] A previous version of Exchange Server is already installed on this computer. Run Exchange Server 2019 Setup from a different computer or remove the previous version of Exchange Server. Questions:

  • Is the machine where the schema is extended needs to be Windows 2019 or could it be W2012R2 ? (I get that the pre-reqs for the server to install the Exchange 2019 software must be W2019, but the actual schema extension itself also needs W2019?)
  • Is the machine where the schema is extended can be the W2012R2 server where Exchange 2013 is running.
Exchange Server
Exchange Server
A family of Microsoft client/server messaging and collaboration software.
1,109 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Andy David - MVP 142.7K Reputation points MVP
    2023-04-10T15:15:47.9333333+00:00

    If you are running the Forest steps for Exchange 2019, you have to run a on supported O/S, yes. You cant run Exch 2019 binaries on a W2012R2 server. https://learn.microsoft.com/en-us/exchange/plan-and-deploy/supportability-matrix?view=exchserver-2019#supported-operating-system-platforms User's image