Scheduled task freezes PC

Pedro Moita 1 Reputation point
2020-10-09T15:17:30.183+00:00

Hi, I have a batch file that zips a network shared folder. If I run it from command line or explorer it runs and finishes in about 3 minutes. I set it up to run from task sheduler and when it does the PC freezes and can't turn it off or restart, I have to remove the power cord. What am I missing? Shouldn't it behave similar if the task uses the same user as the gui? Thanks. Pedro

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,180 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. MotoX80 30,831 Reputation points
    2020-10-10T14:23:07.003+00:00

    What utility are you using to zip the folder? Winzip? Does this utility have an option to log it's activity? If you are using a command line utility you can capture stdout and stderr to see what output it generates. Like this.

    SomeZipProg.exe /parm1 /parm2    1>C:\temp\SomeZipProg.log 2>&1
    

    You could also launch Task Manager and watch the details tab to monitor the performance of the zip program. I would expect that it's using up all of the pc's memory if its freezing. Kill the program before it uses up all of the system's memory.

    0 comments No comments

  2. Pedro Moita 1 Reputation point
    2020-10-12T08:42:59.187+00:00

    I'm using 7Zip's 7za.exe.

    Task manager shows nothing unusual other than being slow to respond and if I close it can't open it again until restart:

    CPU usage under 10% total 7za only uses 1 or 2%, Memory also under 10%, HDDs (I have 2) about 1%, SSD about 2% and Network can't really tell seems to be 500 kb every other second.

    When I run the batch from explorer CPU and memory go up to 50% usage, haven't checked other settings though.

    I'll try to create a log from 7za.exe.


  3. Pedro Moita 1 Reputation point
    2020-10-29T11:07:44.277+00:00

    @MollyLu If it does generate errors in event viewer they get lost on restart, as I can´t find any.

    I did find one record with ID: 1001 Source: Windows Error Reporting with data saying EventName: AppHangTransient and P1: mmc.exe.

    Also found the ones saying Tryed to reboot and didn't shutdown before restart.

    BTW it did perform as it should last time the scheduled task ran

    0 comments No comments