error while deploying linked templates using azure DevOps release pipelines

Venkata Sudheer Nimmakayala 0 Reputation points
2023-04-11T17:52:43.9733333+00:00

Hello All, recieving this error while deploying ARM templates stored in Storage blob container. I provided the template path along with SAS token for the container in my release pipeline task. I also checked if the template link is accessible outside my pipeline it worked. However , I cannot download contents when i am using my release pipeline Please someone facing the same error if you were able to resolve . Please help me

[error]InvalidContentLink: The provided content link 'Azure.Deployments.Core.Entities.DeploymentTemplateContentLink' is invalid or not supported. Content link must be an absolute URI not referencing local host or UNC path.
Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,702 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. PRADEEPCHEEKATLA-MSFT 78,986 Reputation points Microsoft Employee
    2023-04-12T06:49:01.01+00:00


    Venkata Sudheer Nimmakayala
    - Thanks for the question and using MS Q&A platform.

    It seems like you are trying to deploy an ARM template stored in a Storage blob container using Azure DevOps release pipelines, but you are receiving an error message that says "InvalidContentLink: The provided content link 'Azure.Deployments.Core.Entities.DeploymentTemplateContentLink' is invalid or not supported. Content link must be an absolute URI not referencing local host or UNC path."

    This error message usually occurs when the content link provided in the ARM template is not a valid absolute URI. To resolve this issue, you can try the following steps:

    1. Make sure that the URI provided in the templateLink property of the ARM template is a valid absolute URI that can be accessed from outside your pipeline. You can test this by trying to access the URI from a web browser or a tool like Postman.
    2. If the URI is valid, make sure that you have provided the correct SAS token for the container in your release pipeline task. You can check this by comparing the SAS token in your task with the one generated for the container in the Azure portal.
    3. If the SAS token is correct, make sure that the storage account and container names in your task are correct and match the ones in the URI.
    4. If none of the above steps work, you can try using a different method to deploy your ARM template, such as using the Azure CLI or PowerShell.

    I hope this helps you resolve the issue. If you have any further questions or concerns, please let me know.


  2. Madhandra Rupa 0 Reputation points
    2024-02-05T03:10:53.74+00:00

    Need give the -containerUri (storage account Url/containername/directory ) and -containerSastoken (storage account Sas token) In override parameter. It works for me.