How to fix Win11 Taskbar Search not showing Apps ?

Peter Dornauer 35 Reputation points
2023-04-12T14:20:30.0333333+00:00

Hi, when I enter a Document-Name (example PS-Script1.ps1) in the Taskbar-Search Bar I get the appropriate answer and can open the file or find the place of it.
BUT when I enter for example "Word" or "Excel" or "Edge" or "Settings" or "FileMaker"...the I get not the correct answer. For example, is "wordpatterns.xml" if I enter Word or "Excel Handbook.pdf" if I enter Excel. But when I enter "winword.exe" or "Excel.exe" -> the I get the result in the search box.
What's even more strange that also "Settings" gives no result (beside "Mouse-Setting, Start-Setting...which is part of Setting.....but not Setting itself).
i made already chkdsk, sfc, I made an new index on new location, I changed from classic to extended search, i changed the Indexlocation to Startmenue and User Folder ONLY.....but nothing is changing.
So, here I'm lost and dunno what else todo.
The only thing I can think of is: OneDrive making here some nonsense. I have no proof.....it's just my last guess. But i hope somebody here is a Win11 Search-GURU and has the needed superpowers, 'cause without finding apps fast, working is half so good on my PC :-) THX Peter Vienna

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,465 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Karlie Weng 15,191 Reputation points Microsoft Vendor
    2023-04-13T03:07:53.64+00:00

    Hello peter @ Peter Dornauer 

    • Do you have a 3<sup>rd</sup> party shell install on your win11? If the computer has a 3<sup>rd</sup> party shell installed, it may interfere with Search.
    • Compare these settings to the corresponding settings on a working computer. Select Settings > Search > Searching Windows > Advanced Search Indexer Settings. If the index location has been changed from the default, Search might not function correctly. Make sure that the permissions are set correctly on the new location.
    •  You could also rebuild or use Windows PowerShell to reset Windows Search See reference: Fix problems in Windows Search - Windows Client | Microsoft Learn Best Regards
    0 comments No comments

  2. Peter Dornauer 35 Reputation points
    2023-04-13T15:07:15.2966667+00:00

    Hello, tyvm for your response.
    No, I haven't any 3'rd party shell installed, beside Terminal from the MS Store.
    The settings seems the same, but I changed the location of the Index and rebuilt it.
    I gave "System" Full Rights on the new location, but problem solver all the time tells me that the rights are wrong.
    BUT: I tried now with another user account (user2) on this PC and after I logged in, I found immediately all Apps I entered. Word, Excel, everything worked like a charm. So the Index seems Ok.
    This user had also Admin rights so I looked the Index parameters and settings and I notice that they were the same like from my main user !? This is normal behavior ? Cause in the Index was the personal folder of main user instead of user 2.
    But the point was, EVETHING WORKED. Also the Indexlocation is same place like User1 (funnily in User1 Folder). So the Data inside the Index seems valid. But something is messing up the output of user 1. THX also for the Link. I made what was written there and executed also the PS-Script, without success. I also deleted all locations from the Index, beside Startmenue and changed back to classic mode. So it should made fast an index and should get the installed Apps, but it seems I get the same odd answers like before from search. THIS is complete nuts, cause again on USER2 it's working. IS there any Cache of the Index or Catalog or similar ? Or even better, can I completely delete all search data and start over from scratch ?

    Gretz from Vienna Peter D

    0 comments No comments