SQL patching wizard cannot discover installed SSAS instance

Daniel Zhang 20 Reputation points
2023-04-13T04:12:18.0266667+00:00

Recently, when I tried to patch an existing SQL 2016 cluster node, the SP3 patch wizard only shows 1 analysis service is available with related SQL instance, however the other 4 installed analysis services don't show under their related SQL instances. So if I run the SP3 patching, it will only patch the analysis service that discovered by the wizard, as well as all 5 SQL instances, and left the rest of 4 analysis services unpatched. This is odd, since if I failover the cluster to this node, all 5 SQL instances and 5 Analysis Services are all up running fine. All the registry and binary files are all seem good (extracted and compared between two nodes' registry). It just appears those 4 analysis services somehow cannot be discovered by SQL installation wizard, and so cannot be repaired. Just wondering does anyone know how the patching/installation wizard discover the installed SSAS/SQL components? I suspect it might be the registry need to fix so the wizard can discover them. Any ideas?

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,894 questions
SQL Server Analysis Services
SQL Server Analysis Services
A Microsoft online analytical data engine used in decision support and business analytics, providing the analytical data for business reports and client applications such as Power BI, Excel, Reporting Services reports, and other data visualization tools.
1,249 questions
0 comments No comments
{count} votes

Accepted answer
  1. Vahid Ghafarpour 18,885 Reputation points
    2023-04-28T02:46:12.4933333+00:00

    It is possible that there is a configuration issue with the registry entries related to the Analysis Services instances. The SQL Server Setup program uses the registry to identify the installed components and determine which components need to be updated or patched.

    To troubleshoot this issue, you can try the following steps:

    Check the registry entries related to the Analysis Services instances on the affected node and compare them with the registry entries on a working node. Make sure that the registry entries for all the Analysis Services instances are present and correctly configured.

    Run the SQL Server Setup program in repair mode on the affected node and see if it detects the missing Analysis Services instances. If the repair mode does not detect the missing instances, you may need to manually remove and reinstall the instances.

    If the above steps do not resolve the issue, you may need to contact Microsoft Support for further assistance. They can help you diagnose and resolve the issue.

    It's also worth noting that patching a SQL Server cluster can be a complex process, and it's important to follow the recommended procedures and guidelines provided by Microsoft. Before patching a SQL Server cluster, it's a good idea to test the patching process in a non-production environment to ensure that everything works as expected.

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful