Cant connect to website - Cant connect securily to this page

Geezer32 31 Reputation points
2020-10-11T22:54:12.133+00:00

We have a new website running on a 2012r2 server, the site is configured with SSL with cert published from our internal CA. The server is for internal use only it is not exposed to the public

The issue I am having is that many users are getting message in Edge "Cant connect security to this page, might be because of unsafe TLS settings"
The server supports TLS1.2 as do the clients, I have ran a Qualsys test on one of the affected client and it says "good protocol support"

Most of the users are connecting to the core network over a VPN, but I have multiple users using the same VPN and some have this issue and others don't

All clients are Windows 10, they have the root CA certificate installed. network port 443 to the server are open from the client

Chrome also exhibits a similar error message

I've tried disabling the local AV (Symantec) made no difference

what else can I do so these clients can connect to the web page?

thanks

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,128 questions
0 comments No comments
{count} votes

1 additional answer

Sort by: Most helpful
  1. Vicky Wang 2,636 Reputation points
    2020-10-12T08:49:51.093+00:00

    Hi,
    Thank you for posting in our forum, as mvp said, this looks like a network problem, I suggest you go to the network forum to post
    Best wishes
    Vicly

    0 comments No comments