I keep hitting "Storage creation failed" when trying to start up cloud shell for azure learning

Hesmondjeet Oon 0 Reputation points
2023-04-14T02:00:03.1366667+00:00

As part of the Azure learning exercise below, I'm trying to start up my Powershell in order to run the shell commands. Exercise - Create an Azure Virtual Machine However, when I try starting up the PowerShell, it shows the following error: Storage creation failed

{"error":{"code":"AuthorizationFailed","message":"The client 'xxx@xxx.com' with object id 'xxx' does not have authorization to perform action 'Microsoft.Resources/subscriptions/resourcegroups/read' over scope '/subscriptions/xxx/resourcegroups/cloud-shell-storage-southeastasia' or the scope is invalid. If access was recently granted, please refresh your credentials."}}

I tried to wait a day before activating another sandbox (currently at 4/10), but am still hitting this issue. I also tried using incognito to resolve the issue to no avail. Any ideas? #azure-fundamentals

PowerShell
PowerShell
A family of Microsoft task automation and configuration management frameworks consisting of a command-line shell and associated scripting language.
2,135 questions
Azure Training
Azure Training
Azure: A cloud computing platform and infrastructure for building, deploying and managing applications and services through a worldwide network of Microsoft-managed datacenters.Training: Instruction to develop new skills.
1,019 questions
{count} votes

4 answers

Sort by: Most helpful
  1. Ernsdorff, Ron 5 Reputation points
    2023-05-30T21:59:16.7766667+00:00

    I was able to see in the portal that my sandbox account had a cloudshellXXXXXXXXX storage account. All Services --> Storage Accounts --> cloudshellXXXXXXXX(I think this number will be unique for everyone)

    So I navigated to the advance settings in the storage account creation, change to the South Central US which matched what the storage account was using as it's location. Then I was able to create a new file share with a unique name. That allowed me to create the use the bash shell.

    1 person found this answer helpful.

  2. Fabricio Godoy 2,606 Reputation points
    2023-04-14T02:21:19.86+00:00

    Hello @Hesmondjeet Oon
    Apparently the account that is connected is without proper permissions in RBAC on resource grup target.

    • Go to azure AD portal > locate the user > assing an approprieate role-based access on the subscription / resource group > save this is will be fix your problem. Regards.

  3. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more

  4. Martin Adamsson 0 Reputation points
    2023-07-17T12:14:02.86+00:00

    ---this solved my 403 error, Use the lab-provided subscription. Use the existing resource group. Use Central US for the location. Create a new, uniquely named Storage account and a new, uniquely named File Share.

    0 comments No comments