Report Builder 401 Unauthorized Error

NCSD Developer 96 Reputation points
2020-10-12T21:19:05.627+00:00

Hello,

I've looked online for answers to this question, but it's been difficult to find a related question/answer.

I've recently installed Windows 10 Pro and have updated to the "2004" version. I've also recently installed Report Builder version 15.0.19210.0.

When I open Report Builder and try to connect to a remote report server, I get the following error message: "The request failed with HTTP status 401: Unauthorized."

I have even tried adding my username/password credentials for the remote report server to the Windows Credential Manager under the Windows Credentials section at the advice of someone from a nearby work organization. I've double-checked the Internet address for the remote report server and my username/password credentials.

Still, I get the 401 Unauthorized error from earlier when I try to connect to the remote report server.

Is there something more I need to do in order to connect to the remote report server?

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,735 questions
0 comments No comments
{count} votes

Accepted answer
  1. NCSD Developer 96 Reputation points
    2020-10-14T14:43:20.307+00:00

    It turns out that this 401 Unauthorized issue in my case relates to how I need to use a domain prefix in front of my username in Credential Manager under the Windows Credentials section.

    In other words, instead of using my username like this:

    username
    password

    I needed to use this:

    DOMAIN\username
    password

    This is based on a tip I got from Reuben at a neighboring work organization.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. ZoeHui-MSFT 30,881 Reputation points
    2020-10-13T03:45:33.06+00:00

    Hi @NCSD Developer

    It seems the issue is related with the permission.

    Please ensure the account is a member of Domain Admins, is a local admin on the SSRS server and has a minimum of Content Manager rights within SQL Server Reporting Services.

    You may navigate to http://<srs_server>/ReportServer on the machine which installed Report Builder to see if you have the permission to access the remote report server.

    If you don't have the permission, you may need to grant user access to the site.

    For reference:

    https://learn.microsoft.com/en-us/sql/reporting-services/security/grant-user-access-to-a-report-server?view=sql-server-ver15

    If you could open the url correctly, please go to the report manager( http://<srs_server>/Reports) and then choose a report and edit it with report builder for a test.

    Regards,

    Zoe


    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.