Azure Synapse copy data to salesforce fails with unexpected error while processing BULK-API

Barnita Roy Choudhury 20 Reputation points
2023-04-17T19:06:56.6633333+00:00

Hi Microsoft team, I was trying to insert data from SQL pool database to Salesforce but got this error Salesforce Operation Failed: [BatchFailure]JobId:7507Z00000HXkEKQA1, BatchId:7517Z00000GCXx9QAH, Message:Got an unexpected error while processing BULK-API. I have tried reducing batch size and column numbers which i was trying to insert, but no help. can you please look into it?

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
4,451 questions
0 comments No comments
{count} votes

Accepted answer
  1. AnnuKumari-MSFT 31,561 Reputation points Microsoft Employee
    2023-04-18T11:07:32.3133333+00:00

    Hi Barnita Roy Choudhury , Welcome to Microsoft Q&A platform and thanks for posting your question here. As I understand your query, you are trying to copy data from SQL pool to Salesforce but it's landing on error while processing BulkAPI request and I also understand that you have already tried to reduce the batch size as recommended.

    Salesforce has limits for both total API requests and concurrent API requests. Note the following points:

    • If the number of concurrent requests exceeds the limit, throttling occurs and you see random failures.
    • If the total number of requests exceeds the limit, the Salesforce account is blocked for 24 hours. You might also receive the "REQUEST_LIMIT_EXCEEDED" error message in both scenarios. For more information, see the "API request limits" section in Salesforce developer limits or contact the Salesforce developer forum. Check here to get more information about Salesforce request limits. Hope it helps. Kindly accept the answer if it's helpful. Thankyou.

0 additional answers

Sort by: Most helpful