OS Provisioning for VM 'mywinsvr' did not finish in the allotted time. However, the VM guest agent was detected running. This suggests the guest OS has not been properly prepared to be used as a VM image (with CreateOption=FromImage)

KIMYONGSOO1 0 Reputation points
2023-04-18T02:00:40.2233333+00:00

I am currently testing the sharing of Gallery VM images across Azure tenants using app registration. While sharing Linux VM images has been successful, I am encountering errors related to OS provisioning whenever I try to share Windows VM images. Even after recreating the VM images, the same error persists. What could be causing this issue? User's image

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,287 questions
{count} votes

2 answers

Sort by: Most helpful
  1. vipullag-MSFT 25,041 Reputation points
    2023-04-19T04:35:30.5966667+00:00

    Hello P Azure

    Welcome to Microsoft Q&A Platform, thanks for posting your query here.

    The error message you're receiving indicates that the OS provisioning process for your Windows VM is not completing within the allotted time, even though the guest agent is detected as running. This suggests that there may be an issue with the OS image itself that is preventing it from being used as a VM image with the CreateOption=FromImage parameter.

    Few things you can check to try and see if it resolves this issue:

    Check if the Windows VM image is supported for image sharing across Azure tenants.

    Verify that the VM image has been properly generalized before sharing it across tenants.

    Check if the VM image has any dependencies on specific hardware configurations or drivers that are not present in the destination tenant's environment.

    Ensure that the VM image has been fully updated with the latest Windows updates and patches.

    Check the provisioning log files on the VM to identify any specific errors or issues that are occurring during the OS provisioning process.

    Hope this helps.

    If the suggested response helped you resolve your issue, please 'Accept as answer', so that it can help others in the community looking for help on similar topics.

    0 comments No comments

  2. Paul Birtle 0 Reputation points
    2023-04-25T22:45:57.0066667+00:00

    I had the same error but I was not sharing the image across tenants. For me it turned out to be that the Capture process does not do the Generalization. The help text around the selection doesn't make this clear but if you do first Generalize the image then it disables the selection. I can only guess the reason for the selection is if you Generalize an image but don't mark it as Generalized.

    I followed these steps to Generalize the image then captured it again.

    https://learn.microsoft.com/en-gb/azure/virtual-machines/generalize