My DevOps organisation disappeared after linking to a newly created Azure Active Directory

Marcel Slats 1 Reputation point
2020-10-13T07:05:17.82+00:00

I'm doing some setup with DevOps and Active Directory on Azure so we can replace our old OnPremise TFS.
I had created a few organizations and that worked ok with assigned Microsoft Account users.
Then I created an Azure Active Directory, invited some users, and then decided to link one of the organizations to Active Directory.
After that, signoff and signon again...
The organization was no longer accessible from my Microsoft Account (as expected) but also not from my Active Directory.
I tried a second time with another organization to see if I did something wrong but with the same result.

Is this a bug in Azure/Active Directory?
Has anybody seen this before? And how to fix this (= get the organization back in either Active Directory or Microsoft Account)?

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
18,719 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Leon Laude 85,566 Reputation points
    2020-10-13T07:17:44.153+00:00

    Hi @Marcel Slats ,

    Something here might help:
    https://stackoverflow.com/questions/64325574/devops-organization-disappeared-after-linking-to-azure-active-directory

    They're also actively answering in the dedicated Azure DevOps forum over here:
    https://developercommunity.visualstudio.com/spaces/21/index.html

    ----------

    (If the reply was helpful please don't forget to upvote or accept as answer, thank you)

    Best regards,
    Leon


  2. Tim Jonker | Estreme 1 Reputation point
    2021-09-24T13:12:32.553+00:00

    I had the same problem. After linking the devops organization to Azure AD, it disappeared when logging into https://dev.azure.com .
    However, it came back when logging on to https://<organizationname>.visualstudio.com.

    This link explains: https://learn.microsoft.com/en-us/azure/devops/organizations/accounts/connect-organization-to-azure-ad?view=azure-devops

    kind regards,
    Tim

    0 comments No comments