Root domain refuses to connect, but works with www

Taylor Hill 0 Reputation points
2023-04-18T18:57:00.27+00:00

I've got a Google-managed domain that I'm trying to point to an Azure-hosted web application. Currently, the request works fine through the www subdomain, but when connecting through the root domain I get the error "refuses to connect." My desired end result is to have both root and www resolve to the root domain, while forcing https. The certificate is managed through Azure and functions fine through the www subdomain. Here are the current records in Google: User's image

The redacted lines have to do with SendGrid and shouldn't overlap with anything else. I have tried to remove the bindings and the custom domains entirely from the custom domains menu. When I re-add them, they pass validation and add successfully with a managed certificate. But when I run the custom domain add operations test, I get two errors under "URLs that failed assigment to site MySiteName". User's image

This cannot be true, as you see in my records above. These errors are bizarre, and go against all the documentation I have found. What am I missing here?

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,045 questions
{count} votes

1 answer

Sort by: Most helpful
  1. TP 79,066 Reputation points
    2023-04-18T19:05:11.9466667+00:00

    Hi,

    I tested with both root and www and they both work fine. I think it may be something with your local PC's DNS configuration that is causing the issue. Or perhaps you made a change and it took some time to take effect.

    EDIT: Looking at the errors at the bottom of your screenshot, it appears there was DNS propagation delay that is okay now. Azure thought you didn't have necessary DNS records but I checked from my machine and they are correct.

    Please test from completely different device and Internet connection and see if it is working okay. For example, use your mobile phone browser with wifi disabled so it uses mobile data connection.

    -TP