VM does not start on schedule

Piko0165 20 Reputation points
2023-04-20T02:35:18.52+00:00

I’m trying to Azure Lab Services. I set the lab schedule. But VMs not auto starting in time.
What am I doing wrong? I'm using this as reference.

https://learn.microsoft.com/en-us/azure/lab-services/how-to-create-schedules Any help will be appreciated.

Azure Lab Services
Azure Lab Services
An Azure service that is used to set up labs for classrooms, trials, development and testing, and other scenarios.
282 questions
0 comments No comments
{count} votes

Accepted answer
  1. KarishmaTiwari-MSFT 18,642 Reputation points Microsoft Employee
    2023-04-21T07:10:50.0333333+00:00

    @Piko0165 Thanks for posting your query on Microsoft Q&A. Sorry to hear that you're experiencing issues with Azure Lab Services. I'd be happy to help you troubleshoot the problem.

    #1. Can you please check and see if any of these conditions apply to you, which could be causing the issue. Here's how schedules affect lab virtual machines:

    • Template virtual machine is not included in schedules. While creating the lab, did you select template virtual machine?
      User's image
    • Only assigned virtual machines are started. This means, if a machine is not claimed by an end user (student), the machine will not start on the scheduled hours. Is your VM assigned and still not starting as per the schedule?

    #2. Are you only seeing the problem with the auto start or auto shut down is also not working?

    #3. Share the screenshot of the scheduled event so that I can check from my end too.

    #4. Have you also configured automatic shutdown of VMs for a lab plan, by any chance as described here? That might conflict with the lab schedule. See Configure automatic shutdown of VMs for a lab plan .

    #5. Which VM image did you use to create the lab - Windows or Linux?

    Based on the reference you provided, here are some reasons why the VMs might not be auto-starting on time:

    1. Time zone discrepancy: Double-check that the time zone set for the schedule is correct and matches the desired time zone. An incorrect time zone could cause the VMs to start at a different time than expected.
    2. Schedule status: Ensure that the schedule is enabled. A disabled schedule will not auto-start the VMs as expected.
    3. Conflicting schedules: If you have multiple schedules set up, make sure they don't conflict with each other. Conflicting schedules can cause unexpected behavior in the VM auto-start process.
    4. Schedule recurrence: Check the recurrence settings for the schedule. If you've set it to "once" or "weekly," ensure the start date and time are correct. If it's set to "daily," confirm that the start and end times are accurate.
    5. Insufficient resources: Verify that you have enough resources (quota) available to start the VMs. If you've reached your quota limit, the VMs may not start as expected. You can check the usage and available quota in the "Quota and usage" section of the Azure Lab Services portal.
    6. Service Health: Occasionally, Azure services can experience issues. Check the Azure Service Health Dashboard to see if there are any ongoing incidents or maintenance events affecting Azure Lab Services in your region.

    Please check each suggestion shared above and if you are still seeing the issue or have any questions at all, share the requested details in the "comments". Comment is the fastest way of notifying the experts.

    If this helps, please 'Accept answer' and hit Yes for "was this answer helpful" wherever the information provided helps you, this can be beneficial to other community members for remediation for similar issues.

    0 comments No comments

0 additional answers

Sort by: Most helpful