Camera not detected in azure

Eden S 0 Reputation points
2023-04-25T09:03:47.1366667+00:00

Hello, Its my first time using azure VM and I have a machine with this image : https://learn.microsoft.com/en-us/azure/machine-learning/data-science-virtual-machine/tools-included?view=azureml-api-2, for a computer vision project I need acess to a camera that I pluged in, but when I go to the device manager there are no cameras detected (not even the one already inetgreated into my host computer). Few things to note :

  • I have plugged in a flash drive and it is recognized
  • I have enabled remote fx and other group policys that could helps
  • have edited my RDP file to allow cameras and other devices Rdp settings rdp My computer : hostcomputer

The VM clientcomputer

Is there something I'm missing ? Thank you for all your help xxx

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,410 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,342 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. deherman-MSFT 34,691 Reputation points Microsoft Employee
    2023-04-25T21:53:29.57+00:00

    @Eden S

    You might need to edit some GPO on the Local PC and Virtual Machine to access the camera. This page walks you through editing the GPO and settings to redirect the camera. Please check and see if it resolves your issues.

    Hope this helps! If you are still having issues please let me know and we can work with you to further troubleshoot.


    Please remember to "Accept Answer" if any answer/reply helped, so that others in the community facing similar issues can easily find the solution.

    0 comments No comments

  2. Limitless Technology 44,071 Reputation points
    2023-04-26T11:55:35.98+00:00

    Hello Thank you for your question and reaching out. It looks its detected but could not find Drivers , Hence Please try install WebCam driver on Azure VM On your Azure VM : Edit the local group policy Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection -> Disable the setting of policy Do not allow supported Plug and Play device redirection. On your Client PC : Edit the local group policy from the path: Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Connection Client\RemoteFX USB Device Redirection -> Enable the setting of policy Allow RDP redirection of other supported RemoteFX USB devices from this computer. --If the reply is helpful, please Upvote and Accept as answer--