Problem to setup different language during the SCCM OSD with the last Windows 10 21H2 version

Mario Alves 26 Reputation points
2023-04-25T12:48:40.59+00:00

Hello,
Since few weeks i am trying to deploy with Microsoft Endpoint Configuration Manager Windows 10 build 21H2 (version 21H2.16 with April CU) and i keep have an error who says "Why Did the PC Restart ? with blue Screen" With the old build we have, there is no issues and even with Windows 11 Build 22H2, everything works fine. The problem seems to be related to the setting "OSDUILanguage" if we don't use it, the OS is in English but we can access windows, but if we apply another language we have this screen. 2023-04-25_131723

After we choose the language we have access to windows. I found out some others topics about it, but it seems not to work, did someone face the same issue ?
https://www.reddit.com/r/SCCM/comments/yg0es2/windows_10_22h2_language_packs/
https://sysmansquad.com/2021/02/16/multilingual-windows-10-20h2-osd-with-configmgr/ Check the comments. Thank you in advance & have a nice day PS : Thank you Microsoft for deleting real users topic and keeping all the spam and scams in the forum !2023-04-25_144756

Microsoft Configuration Manager
0 comments No comments
{count} votes

Accepted answer
  1. CherryZhang-MSFT 6,481 Reputation points
    2023-04-27T05:33:41.88+00:00

    Hi @Mario Alves

    Thanks for your sharing! We're glad that the question is fixed now. It's appreciated that you could click "Accept Answer" to the helpful reply, this will help other users to search for useful information more quickly. Here's a short summary for the problem.

    Problem/Symptom:
    Get OOBE blue screen and get "Why Did the PC Restart ? “ error when setup different language during the SCCM OSD with the last Windows 10 21H2 version.

    Solution/Workaround:
    Add the following entry in unattend file.

    <SkipUserOOBE>true</SkipUserOOBE>

    <SkipMachineOOBE>true</SkipMachineOOBE>

     

    Thanks again for your time! Have a nice day!

    Best regards,
    Cherry

    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Mario Alves 26 Reputation points
    2023-04-26T06:44:06.7666667+00:00

    Quick update with the main error2023-04-26_082527

    Some additional info: unattend.xml file from Working W10 and W11 staging.

    <?xml version="1.0" encoding="utf-8"?>
    
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    
        <settings pass="oobeSystem">
    
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    
                <InputLocale>%OSDInputLocale%</InputLocale>
    
                <SystemLocale>%OSDSystemLocale%</SystemLocale>
    
                <UILanguage>%OSDUILanguage%</UILanguage>
    
                <UILanguageFallback>%OSDUILanguageFallback%</UILanguageFallback>
    
                <UserLocale>%OSDUserLocale%</UserLocale>
    
            </component>
    
        </settings>
    
        <cpi:offlineImage cpi:source="wim://#/sources/install.wim#Windows 11 Enterprise" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    
    </unattend>
    

    UI file apply with control intl.cpl,, /f:"UIFrench.xml"

    <gs:GlobalizationServices xmlns:gs="urn:longhornGlobalizationUnattend">
        <!--User List-->
        <gs:UserList>
            <gs:User UserID="Current" CopySettingsToSystemAcct="true" CopySettingsToDefaultUserAcct="true" /> 
        </gs:UserList>
    	
        <!--Display Language--> 
        <gs:MUILanguagePreferences> 
            <gs:MUILanguage Value="fr-FR" /> 
            <gs:MUIFallback Value="en-US" /> 
        </gs:MUILanguagePreferences> 
    	
    	<!--system locale--> 
    	<gs:SystemLocale Name="fr-CH" />
    	
        <!--User Locale-->
        <gs:UserLocale> 
            <gs:Locale Name="fr-CH" SetAsCurrent="true" ResetAllSettings="false"/>
        </gs:UserLocale>
    
        <!--input preferences--> 
        <gs:InputPreferences> 
    
            <!--fr-CH-->
            <gs:InputLanguageID Action="add" ID="100c:0000100c" Default="true"/> 
    
            <!--de-CH--> 
            <gs:InputLanguageID Action="remove" ID="0807:00000807"/> 
    
            <!--de-DE--> 
            <gs:InputLanguageID Action="remove" ID="0407:00000407"/>
    
            <!--en-US--> 
            <gs:InputLanguageID Action="remove" ID="0409:00000409"/> 
    
            <!--it-CH-->
            <gs:InputLanguageID Action="remove" ID="0810:00000810"/> 
        </gs:InputPreferences> 
    
        <!--location--> 
        <gs:LocationPreferences> 
            <gs:GeoID Value="223"/> 
        </gs:LocationPreferences>
    </gs:GlobalizationServices>  
    

    Apply Windows settings on the task sequence :2023-04-26_115022

    Regional variables 2023-04-26_115140

    On Windows 11 the LP + FOD were imported to the WIM, with Windows 10 they are added during the staging, but both solutions does the same problem, the LXP are install during the staging on both versions.

    0 comments No comments

  2. CherryZhang-MSFT 6,481 Reputation points
    2023-04-26T09:27:59.28+00:00

    Hi @Mario Alves

    1, Does "OSDUILanguage" setting work for Windows 11 Build 22H2 and the old build?

    2, How did you configure "OSDUILanguage" setting? Could you please upload more details for our reference?

    3, Please help upload a task sequence screenshot and the full smsts.log for our reference.

    4, We may try to select the UI language from Apply Windows Settings step.

    1

    Looking forward to your reply.

    Best regards,
    Cherry


  3. Mario Alves 26 Reputation points
    2023-04-26T13:05:22.9633333+00:00

    I Think i found the issue,
    After adding

    <SkipUserOOBE>true</SkipUserOOBE>
    <SkipMachineOOBE>true</SkipMachineOOBE>
    

    To the unattend file, it seems to work correctly again... i still doesn't get why on W11 and old version of W10 it's still working...

    0 comments No comments