Cannot deploy custom container (python flask app) to linux app service from ACR

dfking 0 Reputation points
2023-04-26T03:39:47.1566667+00:00

I'm trying a simple deployment of a Docker image with a hello world Python flask app, which I've pushed to ACR successfully. I've tried configuring the App Service to pull from ACR in many different ways, but the Deployment Center logs never show any activity or error message. I'm not even sure it's a permissions issue or not because the logs just show just a oneliner:

2023_04_25_lw0sdlwk0007ZT_docker.log:
  1. (I assume it's a permissions issue though because it doesn't even pull the image)
  2. The ACR and App Service app are under the same resource group.
  3. I've tried with a system-assigned managed identity and a user-assigned managed identity. Both have the AcrPull permissions to the ACR. I've also tried with using
  4. I've tried using a service principal and app service config with DOCKER_REGISTRY_SERVER_URL, DOCKER_REGISTRY_SERVER_USERNAME, and DOCKER_REGISTRY_SERVER_PASSWORD
  5. I've tried so many different articles:
    1. Migrate custom software to Azure App Service using a custom container
    2. Run a custom container in Azure
    3. Configure a custom container for Azure App Service
    4. Deploy a containerized Python app to App Service
  6. I've tried deploying straight from vs.code via the docker tab on the left with "Deploy Image to Azure App Service...". This creates the webapp and grants the correct permissions to pull from the ACR.

This is quite frustrating to not even see logs why deployment is failing. Where do I even start to debug or pinpoint where the failure is? Dockerfile:

FROM python:3.11-slim-bullseye

WORKDIR /app

RUN python3 -m venv ${VIRTUAL_ENV}
ENV PATH="$VIRTUAL_ENV/bin:$PATH"

COPY . .
RUN pip3 install --upgrade pip && pip3 install -r requirements.txt

app.py:


import flask

app = flask.Flask(__name__)

@app.route('/')
def index():
    return "Blahblahblah"

if __name__ == '__main__':
    app.run(debug=True)

I've checked the /LogFiles directory for the docker logs and they're all 0 bytes. Is there a way to manually trigger/start a deployment? It's almost like a worker that's responsible for running the deployment is either stuck or not running (?) Thanks...

Azure Container Registry
Azure Container Registry
An Azure service that provides a registry of Docker and Open Container Initiative images.
414 questions
Azure Container Apps
Azure Container Apps
An Azure service that provides a general-purpose, serverless container platform.
310 questions
Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,155 questions
{count} votes