SIGKILL Error when accessing GitHub with Edge browser on Ubuntu 22.04

Jacek Ga 60 Reputation points

Cannot open GitHub with Edge browser on Ubuntu 22.04. Error code SIGKILL. Note that page loads (title is visible), just render fails. DevTools say "disconnected from page".

All other websites I tried work.

Version 112.0.1722.58 (Official build) (64-bit)

Graphics card RTX 4070Ti (there were a lot of problems with it on Ubuntu so it might be relevant, for example Edge didn't launch at all before installing drivers while other browsers did)

This is a fresh Linux and Edge install, I've already tried to clear cookies and restart PC. Github works just fine under Chrome. User's image

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
1,927 questions
{count} votes

Accepted answer
  1. ShiJieLi-MSFT 5,616 Reputation points Microsoft Vendor

    Hi @Jacek Ga ,

    It seems to be a common issue on Microsoft Edge 112.0.1722.58 on Ubuntu. And the Dev Team is currently investigating the issue.

    The temporary workaround is to downgrade Microsoft Edge to 112.0.1722.48. If there's any update on this issue, I'll keep you informed. Thanks for your understanding.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Best Regards,

    Shijie Li

    4 people found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Stephan Boeni 5 Reputation points

    Same issue in openSUSE Tumbleweed with microsoft-edge-stable-112.0.1722.64-1.x86_64.

    not only github, but many other sites as well

    1 person found this answer helpful.
    0 comments No comments