Cannot enable Virtualization / Nesting in a VM

domuncolo 20 Reputation points

what should I do?

what should I run?

what vm size should I use?

please advise.

I have been trying to run vms instances in virtual box in a Azure instace size Standard D2as v4 (2 vcpus, 8 GiB memory) and I cannot bypass this error does not matter if I use a new of old virtual box version.

during VB install I had to install:

+++++++ X64

I checked the forums and I tried to use different sizes based in the following doc but I always have same err.

++++++++ ERR:

Virtual box Version 7.0.8 r156879 (Qt5.15.2)

VM Name: kali-linux-2023.1-virtualbox-amd64

WHvCapabilityCodeHypervisorPresent is FALSE! Make sure you have enabled the 'Windows Hypervisor Platform' feature. (VERR_NEM_NOT_AVAILABLE).

AMD-V is not available (VERR_SVM_NO_SVM).

Result Code: E_FAIL (0X80004005)
Component: ConsoleWrap
Interface: IConsole {6ac83d89-6ee7-4e33-8ae6-b257b2e81be8}



PS C:\Users\jefrey> Get-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V

FeatureName : Microsoft-Hyper-V

DisplayName : Hyper-V Platform

Description : Provides the services that you can use to create and manage virtual machines and their resources.

RestartRequired : Possible

State : Enabled

CustomProperties :

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
6,331 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Support Team 0 Reputation points


    I am having the same problem when running VB, I am using "Standard D8s v3".

    I don't see the Nested Virtualization feature shown in the SIZE page

    Is the above solved ?

    Your feedback please

    0 comments No comments