Exchange 2016 uninstall failing at language pack

Niranjan T Pattana Shetty 286 Reputation points

I have one exchange server whose uninstall is stuck at the language pack step and no matter what i do, it is just not letting the uninstall, below are the things i have done:

  1. Restarted it like a 10 to 20 times.
  2. Left overnight and then tried again.
  3. Downloaded CU21 ISO file and then mounted and and ran the uninstall from the drive i mounted , still failed.
  4. I tried from the install files that existed in one of the drives, it failes there too

I have just ran out of options

Exchange Server
Exchange Server
A family of Microsoft client/server messaging and collaboration software.
807 questions
Exchange Server Development
Exchange Server Development
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Development: The process of researching, productizing, and refining new or existing technologies.
466 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
6,994 questions
Microsoft Exchange
Microsoft Exchange
Microsoft messaging and collaboration software.
281 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Amit Singh 4,456 Reputation points

    Based on my research, one of the possible causes of this issue is the antivirus. The solution is to disable the real-time protection of your antivirus before installing or upgrading Exchange. Ensure you have all the exceptions in place, as this Microsoft TechNet article outlines. 

    See Exchange Install Hangs on Languages Step for more details.

    0 comments No comments

  2. Jarvis Sun-MSFT 8,001 Reputation points Microsoft Vendor

    Hi @Niranjan T Pattana Shetty ,


    Please provide more detailed error message to help further troubleshooting. By my experience, I have below suggestions for your reference.


    1.Please try to use the command below via Command Prompt(run as Administrator) to see if the uninstallation can be successful.

    Setup.exe /mode:Uninstall /IAcceptExchangeServerLicenseTerms


    2.If the cmd doesn’t work, please run ADSIEdit.msc and remove Exchange 2016 from the location below: 

    CN=configuration -> DC=domain name,DC=com -> CN=Services -> CN=Microsoft Exchange -> CN=<YourExchOrgName> -> CN=Administrative Group -> CN=Exchange Administrative Group -> CN=Servers

    (Important: ADSI Edit must be handled with care. Modifying the attributes using ADSIEdit can cause significant issues with your infrastructure if something is done in a wrong way. We would suggest you make a backup before modifying.)

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments