Opening a Link to a Powerapps Custom Link Form/ List view in the Quick Launch causes a Out of Memory Error

Damien Bryan 21 Reputation points
2020-10-15T04:36:06.757+00:00

Hi,

In our Quick Launch we have links to certain Lists, Info Path Forms, Powerapps Forms among other links. When our users click a link to a Sharepoint Custom Powerapp Form that is saved in the Quick Launch it takes them to https://<Tenant>.sharepoint.com/_layouts/15/listhost.aspx and the page after about 30 seconds will time out and returns: Error code: Out of Memory.

THis happens in Edge and Chrome.

This also happens for a link to a saved list view in the quick launch.

Strangely if I copy the link and manually go to it or open the link in a new Tab the form and list load instantly. This has only started happening within the last week.

For both links when it gets to listhost.aspx i get the below error logged in the console.

Uncaught TypeError: Cannot read property 'querySelectorAll' of null
at Function.t._queryFocusableSelector (sp-pages-assembly_en-au_c2ba82505d0b58b27a6e436327d1acb5.js:1)
at Function.t.getFirstFocusableChild (sp-pages-assembly_en-au_c2ba82505d0b58b27a6e436327d1acb5.js:1)
at chunk.sp-command-bar-deprecated_en-us_1b41146a17894f5e5334.js:1

Any Help would be greatly appreciated.

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,209 questions
{count} votes

Accepted answer
  1. Echo Du_MSFT 17,091 Reputation points
    2020-10-15T08:03:24.037+00:00

    @ DamienBryan-3303

    You could refer to the solution provided by Microsoft official to solve "Browser running out of memory" problem.

    "If you run out of memory while using Power Apps, please consider downloading a 64-bit version of Chrome, Microsoft Edge, or Internet Explorer."

    The above information from Common issues and resolutions for Power Apps.

    Thanks,

    Echo Du

    @ DamienBryan-3303

    ………………………………Updated Answer………………………………

    Per my test, I could not reproduce your issue. It might be an intermittent problem.

    Please try the following points to troubleshoot this issue:

    1.Clear cache of your Chrome, then sign in your SP list, try your custom form/list again, check if the issue is solved.
    2.Open the "Developer Tool" in your Chrome browser, to track the Network condition, find which request cause the High CPU Utilization:
    32841-2.png

    3.Turn off the Preview feature to reduce memory consumption and load times .
    Edit the custom form/list >> click File tab >> select Settings tab, then select Advanced settings option >> In the Search box, select Preview features under the "All" list >> turn off features which you needed,such as "Use non-blocking Onstart rule" or "More reliable Concurrent function".
    32765-1.png

    4.Please re-start your PC, then try it again, check if the issue is solved.
    5.Please consider removing the custom form/list, and then create a new one for it.

    If the issue still exists, please consider submit an assisted support ticket for help through the following link:
    https://powerapps.microsoft.com/en-us/support/pro

    Thanks,
    Echo Du

    =============

    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


2 additional answers

Sort by: Most helpful
  1. SHEPHERD, Steven 1 Reputation point
    2020-10-16T09:14:10.883+00:00

    I'm also getting the exact same thing

    Only when opening from quick launch - opening the list from contents or another route works just fine

    Using Edge Version 86.0.622.38 (Official build) (64-bit)

    0 comments No comments

  2. Conrad Agramont 1 Reputation point
    2021-09-14T20:11:40.877+00:00

    I ran into this same issue when working with the Microsoft 365 Learning Pathways SharePoint template. I was trying to do a restore and following the instructions below made it crash.

    https://github.com/pnp/custom-learning-office-365/blob/main/installation/BackupInstructions.md

    When you look at the CustomConfig list, it crashes each time. I think it's because of all the JSON data which is field in the view to show. I just wanted to see the list overall and didn't need the data (yet). So I made a custom view and got me what I needed.

    Once I did need the JSON data, I opened Excel and used the Data import feature connecting to SharePoint Online for the SharePoint list and I got everything I needed.

    It's not a fix, but maybe this helps you get to the data you need.

    0 comments No comments