Outlook for Office 365 linked image cannot be displayed

Ron Hinds 10 Reputation points
2023-04-30T16:22:30.2266667+00:00

This issue started for me about two weeks ago. Prior to that, everything worked fine. Note that it is not happening on all messages, only about half of them exhibit the problem. If I click on "If there are problems with how this message is displayed, click here to view it in a browser", Edge opens it in Internet Explorer mode and the images still do not display. Interestingly, if I right click on one of the non-displaying images in IE mode and select Properties, then copy the URL of the image and paste it into a new Edge (regular) tab, the image displays correctly. Which seems to eliminate any possibility of it being a firewall or DNS issue.

What I've tried so far.

Verified that the BlockHTTPimages registry value is set to 0

Flushed all temporary files from cache, including system temp files (using CCleaner)

Updated Office 365

Updated motherboard BIOS

Updated all drivers

Specs on my system

Device name XXX-XXX

Processor AMD Ryzen 7 1700X Eight-Core Processor 3.40 GHz

Installed RAM 32.0 GB

Device ID XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX

Product ID 00342-50436-28212-AAOEM

System type 64-bit operating system, x64-based processor

Pen and touch No pen or touch input is available for this display

Edition Windows 10 Pro

Version 22H2

Installed on ‎3/‎13/‎2021

OS build 19045.2913

Experience Windows Feature Experience Pack 1000.19041.1000.0

Microsoft® Outlook® for Microsoft 365 MSO (Version 2304 Build 16.0.16327.20200) 64-bit

Outlook
Outlook
A family of Microsoft email and calendar products.
3,228 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Dan Nowlan 0 Reputation points
    2023-05-17T17:04:48.27+00:00

    I'm having the same problem. I've looked at the Trust Center, Internet Settings, registry values, etc. Nothing helps.

    User's image


  2. ChristyZhang-MSFT 21,591 Reputation points Microsoft Vendor
    2023-05-18T07:20:25.0766667+00:00

    Hi @Ron Hinds ,

    Did you receive the same error as Dan Nowlan mentioned?

    If so, as i know, this issue occurs when the BlockHTTPimages registry value is set to 1 and the images in the email message have a source that points to a URL. Please refer to this article and try to modify the registry: The Linked image cannot be displayed error in an Outlook email message.

    9

    (Note: Serious problems can occur if you modify the registry incorrectly. Before making changes, back up the registry to restore it in case something goes wrong.)


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  3. Dan Nowlan 0 Reputation points
    2023-05-18T08:08:00.1866667+00:00

    I should have been more specific. When I mentioned registry values, I explicitly searched the entire registry for that string—BlockHTTPimages—and found nothing.