Remote Desktop 0x4 error - suddenly and with no reason

Andreas Carlsson 25 Reputation points
2023-05-01T10:50:58.08+00:00

Last week I connected to a remote PC. Today I get an error and can't connect. I have changed nothing on any of the involved machines, what can have happened?

Details:

  • Old HP Server with VMware on it.
  • Remote virtual PC: Windows Server 2003 R2.
  • I connect to the network with VPN.
  • I am able to connect to the virtual PC via VMware.
  • My client is macOS Ventura 13.3. I have also tried with an older Mac, same error. I have also restarted my Mac.
  • I have tried from a different network, same error.
  • I have restarted the PC twice, whereas one of the times was a shutdown.
  • I have verified that Remote Desktop is turned on, which it is. (attached screenshot). (And yes – all users are checked.)
  • The only thing that I noticed was that the remote PC was extremely slow when I connected to it via VMware this morning. This slowness vanished after restart.

Since everything works as it should when connecting via VMware, my guess is that either firewall (on my side or the PC side, or the ISP), is the culprit. How can I verify that? Is it possible to ping the RDP port to see if it's open somehow?

Edit: I just realized that I have a virtual Windows 10 on the same machine, so it's most likely not the firewalls, unless RDP in Windows 10 don't use the same port as 2003…

It seems so effin random. No restarts, no changes, no updates. Please help! 🤪

Skärmavbild 2023-05-01 kl. 12.47.05

Skärmavbild 2023-05-01 kl. 12.35.10

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,403 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,330 questions
0 comments No comments
{count} votes

Accepted answer
  1. Keir 80 Reputation points
    2023-05-01T16:56:40.2266667+00:00

    We are having the same problem. Looks to be since the RDP app update released last week. Only seems to prevent connections to Windows Server 2003.

    1 person found this answer helpful.
    0 comments No comments

6 additional answers

Sort by: Most helpful
  1. Andreas Carlsson 25 Reputation points
    2023-05-02T05:19:05.7066667+00:00

    Thanks for the input! 👍

    Strange. I tried from a Mac with an older version of RDP, and it didn't work either.

    Edit: It turns out that it hade auto-updated. They are both on 10.8.2. Is there any way to downgrade?

    Any news from MS?

    0 comments No comments

  2. Andreas Carlsson 25 Reputation points
    2023-05-02T06:30:32.88+00:00

    Thankyou Keir!

    I found v10.5.2 on MacUpdate.com, and now I can connect again!

    For those who are having the same problem this version can be found here: https://www.macupdate.com/app/mac/8431/microsoft-remote-desktop/old-versions

    That's a couple of hours of my life I will never see again… 😝

    0 comments No comments

  3. Brent Long 1 Reputation point
    2023-08-07T13:24:35.1633333+00:00

    Same issue here, happened around the same time. Can no longer connect to one of my Azure VMs. I have to connect via an unaffected one that's in the same vnet. No real help from Microsoft, and I can't even create a ticket for it without signing up for advanced support.

    0 comments No comments

  4. Andreas Carlsson 25 Reputation points
    2023-09-11T14:25:24.7766667+00:00

    Any news on this?

    I have turned off autoupdate because I don't want to get locked out again.

    0 comments No comments