MS Exchange 2019 - Out Of Office reply doesn't work for external email sender

Federico Coppola 80 Reputation points
2023-05-02T05:55:41.4233333+00:00

Hi all,
I have three host running MS Exchange 2019 CU12.
We are facing the following issue concerning Out-Of-Office auto reply message:
MS Exchange doesn't generate OOF automatic replay for messages that come from outside organization.
OOF seems to work with internal email.

In my case we have just one "Remote Domain". I checked online and I understood default configuration value is "False" for AutoReplyEnabled and AutoForwardEnable if you have MS Exchange on-premise.

[PS] C:\Windows\system32>Get-RemoteDomain | fl DomainName,AllowedOOFType,AutoReplyEnabled,AutoForwardEnabled
DomainName       : *
AllowedOOFType   : External
AutoReplyEnabled : False
AutoForwardEnabled: False

Moreover I tried to send many times email from external e-mail (for example @outlook.com) to this MS Exchange deployment. Only one time I got OOF, however I sent more or less ten mails to the same mailbox.

Some suggestion for me?

Thanks in advance!

Exchange Server
Exchange Server
A family of Microsoft client/server messaging and collaboration software.
1,141 questions
Exchange Server Development
Exchange Server Development
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Development: The process of researching, productizing, and refining new or existing technologies.
522 questions
0 comments No comments
{count} votes

Accepted answer
  1. Jarvis Sun-MSFT 10,176 Reputation points Microsoft Vendor
    2023-05-02T08:27:09.43+00:00

    Hi @Federico Coppola ,

     

    “Only one time I got OOF, however I sent more or less ten mails to the same mailbox.”

    According to this official documentation: Understand and troubleshoot Out of Office (OOF) replies - Exchange | Microsoft Learn

    It mentions that if automatic replies are enabled, only one reply is sent to each sender even if a recipient receives multiple messages from a sender.

     

    If you want to send a response to the sender every time instead of only one time, you can apply the "have server reply using a specific message" mailbox server-side rule instead of using the OOF rule. This alternative rule sends a response every time that a message is received.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.
    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Federico Coppola 80 Reputation points
    2023-05-02T19:30:05.3733333+00:00

    Hello @Jarvis Sun-MSFT

    According to this official documentation

    This KB is about Microsoft Exchange Online. In my case I am running Exchange 2019 CU12.
    Is still valid this knowledge base for my scenario?

    It mentions that if automatic replies are enabled, only one reply is sent to each sender even if a recipient receives multiple messages from a sender.

    I got OOF aut-reply only after that I sent different mail just for a mailbox.
    I recreated the same scenario with a new mailbox on the same exchange server.
    I did not get any auto-reply despite of I configured OOF.

    Thanks a lot for your help!


  2. Federico Coppola 80 Reputation points
    2023-05-29T13:50:26.6633333+00:00

    Hello
    I applied configuration suggested

    Set-RemoteDomain Default -AutoReplyEnabled $true -AutoForwardEnabled $true
    
    

    Unfortunately the issue persist.