No internet when connected to Azure VPN point to site

Andy Bolk 0 Reputation points

We use Azure VPN to connect our local laptops to our Azure VNet to then connect to Azure file shares. Within the last day our VPN connection still works, but then we lose all internet connections once connected to VPN. We have rest the VPN Gateway and that has not resolved the issue. Any help is appreciated.

Azure VPN Gateway
Azure VPN Gateway
An Azure service that enables the connection of on-premises networks to Azure through site-to-site virtual private networks.
977 questions
{count} votes

1 answer

Sort by: Most helpful
  1. KapilAnanth-MSFT 14,851 Reputation points Microsoft Employee

    @Andy Bolk

    Welcome to the Microsoft Q&A Platform. Thank you for reaching out & I hope you are doing well.

    You informed you were doing a lab with Azure AD DS (and everything worked just fine) and then deleted that, however, post this you lost internet connectivity when connected to Azure VPN Client.

    I suggested to,

    • Check if you are learning the default route from the VPN gateway
    • Redownload the configuration file and re-import it to the VPN Client.
    • Check if this is happening with multiple devices or with only a specific machine?

    And to isolate if this is connectivity issue or DNS issue.

    • After connecting to the P2S VPN
    • Open Powershell as admin and Run tnc -p 443
    • If the above worked, Run tnc -p 443

    But you informed that you reconfigured the Azure AD DS and removed it once more, which resolved the issue.

    If you could reproduce this behavior at will (in a Test environment), we could look deeper into this and isolate and mitigate the issue.

    I am afraid the details we have currently cannot help us arrive at a definitive conclusion on the root cause.

    Kindly let us know if this helps or you need further assistance on this issue.



    Please don’t forget to close the thread by clicking "Accept the answer" wherever the information provided helps you, as this can be beneficial to other community members.

    0 comments No comments