Messages are taking too long to leave the Outlook outbox

rafael9908 20 Reputation points
2023-05-03T17:47:54.1933333+00:00

Hi,

I have an Exchange Server 2019 infrastructure and since last week users have been complaining about messages taking too long to leave the Outlook outbox. It takes at least 30 seconds for the messages to get sent.

It happens to messages sent to the organization and also outside the organization.

I've been looking for what might be causing this issue but haven't come with anything up for yet.

Have anyone been through this before? Any ideias?

Thank you.

Exchange Server
Exchange Server
A family of Microsoft client/server messaging and collaboration software.
1,151 questions
Outlook
Outlook
A family of Microsoft email and calendar products.
3,269 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,447 questions
0 comments No comments
{count} votes

Accepted answer
  1. Jarvis Sun-MSFT 10,181 Reputation points Microsoft Vendor
    2023-05-04T05:39:31.8133333+00:00

    Hi @rafael9908 ,

     

    According to your description, please confirm some questions to narrow down the issue to client side or server side.

    Please clarify whether the issue happens to all users or specific users.

    Please try to send mails via OWA or Online mode. If the problem no longer occurs, it is related to the client side.

     

    For client side, you can follow below steps:

    1.Check if “Send Immediately” is enabled in Advanced settings.

    2.Recreate user profile.

    3.Please login on the user’s mailbox on another normal machine to test.

     

    For server side, you can follow below steps:

    1. Make sure that the server has the latest cumulative and security updates installed.

    2.Please watch the event logs for any warnings or errors and consider starting Performance Monitor and watching key performance metrics.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. rafael9908 20 Reputation points
    2023-05-04T11:38:05.88+00:00

    Hi Jarvis, thank's for the reply.

    As I said, the users started coplaining last week. Recreating the profiles or checking the configuration on every single outlook wasn't an option.

    I was using the Exchange Server 2019 CU12 with all the security updates applied.

    After applying CU13 last night everything seemed to have gone back to normal, at least for my tests so far.

    I'm going to keep on testing and if anything new show up I'll let you know, but apparently, it has solved the problem.

    Thanks again.

    Best Regards,

    Rafael

    0 comments No comments