Azure Private DNS Resolver deployment failing with circuit breaker

James Smith 0 Reputation points
2023-05-04T17:48:19.5166667+00:00

I am trying to deploy an Azure Private DNS resolver via the Azure Portal and I'm getting an obscure message about "Operation has exceeded maximum processing count." and "circuitBreaker=[state=Open, processedCount=6, maxProcessedCount=5]"

{
    "status": "Failed",
    "error": {
        "code": "InternalServerError",
        "message": "Operation has exceeded maximum processing count. dnsResolverResourceId=/subscriptions/xxx/resourceGroups/xxx/dnsResolvers/xxx, circuitBreaker=[state=Open, processedCount=6, maxProcessedCount=5]"
    }
}


The inbound subnet and outbound subnet are both dedicated /24's that are delegated to Microsoft.Network/dnsResolvers. I just have one virtual network and want the resolve to help with VPN client traffic.

I'm trying to deploy this in Canada Central

Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
2,244 questions
{count} votes

5 answers

Sort by: Most helpful
  1. ChaitanyaNaykodi-MSFT 24,001 Reputation points Microsoft Employee
    2023-05-04T23:17:39.7433333+00:00

    @James Smith

    Welcome to the Microsoft Q&A forum.

    Based on the error received

    Operation has exceeded maximum processing count. dnsResolverResourceId=/subscriptions/xxx/resourceGroups/xxx/dnsResolvers/xxx, circuitBreaker=[state=Open, processedCount=6, maxProcessedCount=5]

    This issue can occur if the Microsoft.Network namespace is not registered in your subscription. This requirement is mentioned here in the pre-requisites for Private DNS resolver.

    If the Microsoft.Network namespace is already registered. Can you please try to re-register for it and see if it resolves the issue? (Please allow some time to pass before trying to deploy private DNS resolver again.)

    User's image

    Hope this helps! Please let me know if the issue still persists. Thank you!


    ​​Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    0 comments No comments

  2. Andrew Wood 0 Reputation points
    2023-05-09T09:10:52.61+00:00

    The only way I got round this issue today was by deleting all my networking resources and recreating them. I've been deploying the same resources for months on a daily basis with no issue.

    Sorry my answer may not help you specifically, but wanted to share the way I got round this.

    I did re-register the resource provider too, but initially that wasn't working. Though it may have resolved the issue also

    0 comments No comments

  3. msrini-MSFT 9,266 Reputation points Microsoft Employee
    2023-05-19T05:58:04.4266667+00:00

    Hi,

    I just checked few incidents of same error and looks like this issue is fixed now. Can you try to re-trigger this deployment and check if that works ?

    Regards,

    Karthik Srinivas

    0 comments No comments

  4. Christian BEZENCON 0 Reputation points Microsoft Employee
    2023-06-16T06:31:34.64+00:00

    I just got the same error right now.

    Outbound Endpoint Name: "dev-dnspr-out-eastus"): polling after CreateOrUpdate: Code="InternalServerError" Message="Operation has exceeded maximum processing count. outboundEndpointResourceId=/subscriptions/xxxx/resourceGroups/dev-connectivity-eastus/dnsResolvers/dev-dnspr-eastus/outboundEndpoints/dev-dnspr-out-eastus, circuitBreaker=[state=Open, processedCount=6, maxProcessedCount=5]"

    My azurerm config

      required_providers {
        azurerm = {
          source  = "hashicorp/azurerm"
          version = ">=3.54.0"
        }
    

  5. Evgeniy Savchenko 0 Reputation points
    2024-02-22T08:35:31.6733333+00:00

    I'm getting this error when I'm trying to create DNS private resolver inbound or outbound endpoints from Terraform. It fails every time with the same unclear error.

    {\"status\":\"Failed\",\"error\":{\"code\":\"ResourceOperationFailure\",\"message\":\"The resource operation completed with terminal provisioning state 'Failed'.\",\"details\":[{\"code\":\"InternalServerError\",\"message\":\"Operation has exceeded maximum processing count. outboundEndpointResourceId=/subscriptions/ab4a009b-26fb-40dd-86d7-38054e73a947/resourceGroups/private-dns-rg-stg/dnsResolvers/private-dns-resolver-stg/outboundEndpoints/vwan-private-dns-resolver-endpoint-out-stg, circuitBreaker=[state=Open, processedCount=6, maxProcessedCount=5]\"}]}}
    

    1

    2

    I tried to re-register the Microsoft.Network provider as suggested above, it didn't help. Does anybody understand what the reason of the problem and how to fix it?