Sigcheck not installed correctly. I want to fix this and be able to use sigcheck

LxNevul 20 Reputation points
2023-05-05T18:22:17.48+00:00

I have downloaded Sigcheck(Sysinternals) from Microsoft resources. I ran the installer and the Accept Privacy and Use Rights Agreement window opened. I accepted the conditions and for an instant the terminal opened and immediately closed. I opened the terminal to check if 'Sigcheck' was already installed and it wasn't.

From that point on, every time I run the sigcheck installer, it no longer shows the terms of use window, instead it momentarily opens CMD and closes right away.

Now it won't let me install the tool. And I don't know how to uninstall it if it is, although neither cmd nor powershell recognize the command.

I already restarted the computer, ran sfc /scannow, checked the event viewer for possible errors and there is nothing.

Sysinternals
Sysinternals
Advanced system utilities to manage, troubleshoot, and diagnose Windows and Linux systems and applications.
1,114 questions
0 comments No comments
{count} votes

Accepted answer
  1. MotoX80 32,526 Reputation points
    2023-05-06T00:22:16.1633333+00:00

    Where are you getting this Sigcheck installer? I have been using the Sysinternals tools since the late 90's and I have never seen an installer. You just download the ZIP file, extract the program and run it.

    https://learn.microsoft.com/en-us/sysinternals/downloads/sigcheck

    Sigcheck is a command line utility, so you have to open a cmd prompt or a Powershell window, CD to the folder where you put the files and run it from there. I put my utilities in C:\Utils.

    User's image

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. LxNevul 20 Reputation points
    2023-05-06T15:22:25.3733333+00:00

    Well, I have explained myself badly because of that detail, when I say "installer", I mean the executable that comes in the ZIP file.
    However I already saw the problem, it was not in the directory of the utility. Thank you, your answer was helpful. @MotoX80

    0 comments No comments