Windows Defender / Security : enhanced hardware security missing

Leevaille 0 Reputation points
2023-05-07T01:01:03.7533333+00:00

Hi, since the last update, all enhanced hardware security options have disappear from the device security / Core isolation Tabs, including :

  • Memory Access Protection (Kernel DMA Protection)
  • Kernel mode hardware enforced stack protection
  • Firmware protection

They all was here before.

Memory Integrity is here, and turned On.

I also have a warning : Local Security Authority is Off. Your device may be vulnerable.
But since the option to turn Local Security Authority On or Off doesn't exist anymore since some updates, I enabled it through the registry (RunAsPPL and RunAsPPLBoot Keys) and the warning is gone.

I have the message "Your device meets the requirements for enhanced hardware security", like before, but none of these settings are shown.

My PC Specs :

  • Motherboard : MSI MAG B660 TOMAHAWK WIFI ATX
  • Processor : Intel Core i7-12700F
  • Graphic Card : PNY GeForce RTX 4070 Ti VERTO
  • Memory : Kingston FURY Beast DDR5 16Go 4800MT/s
  • PSU : be quiet! Pure Power 12 M – 850W

Secure Boot is enabled, TPM 2.0 too, DEP too.
UEFI MAT seems okay, even if I'm not really sure about it. But Windows launch itself in UEFI Boot.

I have Windows 11 Pro.

I wonder how can I have these options back, cause my system seems to support them, so I don't understand why they're not here.

Thanks for your time

Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,933 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,617 questions
{count} votes

3 answers

Sort by: Most helpful
  1. S.Sengupta 16,481 Reputation points MVP
    2023-05-07T01:19:51.4633333+00:00

    Reset Windows Security:

    • Open Settings.
    • Click on App settings
    • Search for Windows Security
    • Click on the 3 dots and select Advanced option
    • On the next page, click on the Reset button in Settings.
    • Click on Reset to confirm.
    • =====================

    Reset via PowerShell (as Admin)

    copy-paste the following command:

    Get-AppxPackage Microsoft.Windows.SecHealthUI | Reset-AppxPackage

    =========================

    You can also reinstall the app via PowerShell (admin)

    PowerShell -ExecutionPolicy Unrestricted -Command "& {$manifest = (Get-AppxPackage Microsoft.Windows.SecHealthUI).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest}"


  2. Nitzan 0 Reputation points
    2023-05-07T05:01:55.9633333+00:00

    I've encountered this too, resetting doesn't help.
    following

    0 comments No comments

  3. Harry.K 0 Reputation points
    2023-05-12T21:07:54.0366667+00:00

    Same for me. Had it disabled and after some time wanted to turn it on, but the option disappeared. the warning about turning it on stayed till I reset my PC.
    i9 13900K,
    z790 Rog strix motherboard

    0 comments No comments