VM crash issue while compiling Visual Studio projects

2023-05-08T07:38:01.35+00:00

I have Visual Studio 2015(Enterprise edition) installed on Windows 10 Virtual Machine. Whenever I try to build/compile VC++ application in Visual studio then VM is crashing.

Issue : Windows 10 VM crashes with an error message(event logger) “The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.”.

Following solutions are tried with no luck.

  1. Increased RAM size to 32GB
  2. By changing VC++ project setting i.e. 'Maximum concurrent C++ compilations' to '4'.
  3. Set affinity
Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
3,172 questions
{count} votes

1 answer

Sort by: Most helpful
  1. AnnaXiu-MSFT 15,166 Reputation points
    2023-05-08T09:22:03.66+00:00

    Hi @Madasnal, Daryappa, 

    Welcome to Microsoft Q&A! 

    Do you mean that it only occurs in building VC++ project? Can you create other projects and check again? 

    The error message usually indicates that your Windows shuts down incorrectly.

    Please refer to: Event ID 41: "The system has rebooted without cleanly shutting down first"

    You can check for your Windows updates and try to repair your VS2015 by opening your Control Panel > Uninstall or change a program > search it > right-click on “Change”. 

    Sincerely,

    Anna


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

     

    0 comments No comments