DP 203 setup file fails

Simon Firestone 45 Reputation points
2023-05-09T13:04:35.4866667+00:00

I'm trying to do the DP-203 training module on Azure. I copied the repo successfully, but get errors from the setup.ps1 file. Here are the steps I've already taken

*I used chmod to make the file executable.

*I tried running it but get these errors:

/setup.ps1: line 1: Clear-Host: command not found

./setup.ps1: line 2: Get-Date: command not found

./setup.ps1: line 2: write-host: command not found

./setup.ps1: line 5: =: command not found

./setup.ps1: line 5: Select-Object: command not found

./setup.ps1: line 6: syntax error near unexpected token `.IsArray'

./setup.ps1: line 6: `if($subs.GetType().IsArray -and $subs.length -gt 1){'
*I tried to change the version of bash to 5.1 but it asked for an administrator password but I don't think I have one.

Any advice? Are there updated instructions or setup files anywhere? Thanks!

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
36,967 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Md Amjad Hussain 0 Reputation points
    2024-04-14T05:58:27.0233333+00:00

    use powershell , it will work there

    0 comments No comments