[Resoled][SharePoint SE]We are not able to login SharePoint SE on-premise site, prompting credentials popup again and again

Thành Tiến Trương 20 Reputation points
2023-05-10T09:43:20.2433333+00:00

My case is: I have synchronized users from AD but when using AD user account to log in to SP site, the login request window keeps appearing.

I have researched below 2 q&a have similar situation to my problem

https://learn.microsoft.com/en-us/answers/questions/459676/we-are-not-able-to-login-sharepoint-2016-on-premis

https://learn.microsoft.com/en-us/answers/questions/956996/sharepoint-issue-log-in-user-account-active-direct

and I fixed it in the direction of DisableLoopbackCheck and BackConnectionHostNames but it didn't fix the issue.

The strange thing here is: I have 2 groups of users with the same domain

Group 1 is admin accounts, then access to SP

Group 2 is normal accounts that can't access SP

I don't know if anyone has had the same problem as me and has a solution to solve this problem?

Image of log user normal login

q&a microsoftUntitled

Note: I have added a user to the group that has permission to access the SharePoint site

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,273 questions
{count} votes

Accepted answer
  1. Ling Zhou_MSFT 14,605 Reputation points Microsoft Vendor
    2023-05-18T07:33:08.8566667+00:00

    Hi @Thành Tiến Trương,

    I'm glad your problem was solved, and I learned a lot from your solution. Thank you for sharing your sparkling ideas!

    Now I'll summarize this problem of user in AD group not being able to login to SharePoint.

    Troubleshooting is as follows:

    1. Check if the group is added to Deny access via network.
    2. Check if the group have permission to SharePoint. (Settings > Site settings > Site permissions > Check Permissions)
    3. Remove group permissions and re-add permissions.
    4. Clear the browser cache and try again to access the SharePoint Site.

    Please click "Accept Answer" and kindly upvote it, as it will help others who are facing the same problem as you. Thank you for your understanding and cooperation!


    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Ling Zhou_MSFT 14,605 Reputation points Microsoft Vendor
    2023-05-11T10:06:47.6966667+00:00

    Hi @Spacezyx,

    Thank you for posting in the community.

    First, let me confirm your problem: One of your groups in AD cannot access SharePoint Site, and always pops up the login verification. Your Group 1 can access SharePoint, but not Group 2. It is likely that Group 2 does not have permissions.

    You can troubleshoot your problem by doing the following:

    • You can change your browser or use privacy mode to re-access SharePoint.
    • Please check whether these users in Group 2 have SharePoint site permissions or not.

    Settings > Site settings > Site permissions > Check Permissions

    User's image

    • These Group 2 users could try to sign out and sign in again to have their security token updated with the new groups.
    • You could try to add Group 2 to SharePoint site directly.

    Settings > Site settings > Site permissions > Grant Permissions > Show options > Select "Read" permission level. (Choose the permission you need)

    User's image

    • After all the above problems have been solved, please clear your browser cache data and log back into your account in AD to access SharePoint Site

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    0 comments No comments

  2. Thành Tiến Trương 20 Reputation points
    2023-05-12T02:18:28.4333333+00:00

    Hi @Ling Zhou_MSFT ,

    Thank you for the reply.

    I have done the above steps you suggested but the team 2 accounts still cannot access the SharePoint site.

    I also tried adding user group 2 to site collection admin but user group 2 still cannot access.