Having OneDrive automatically sync files

Knox 26 Reputation points
2020-10-16T01:35:26.187+00:00

I recently switched from Dropbox to OneDrive and I cannot for the life of me figure out how to make OneDrive automatically sync all files, all the time.

With Dropbox it was easy. You don't have to do anything. A file gets updated on one computer or from the web and it syncs it everywhere else automatically.

With OneDrive I make changes to a file on another computer earlier in the day, and then in the evening when I get home it still hasn't updated and I don't even see any options to force it to sync the files.

Surely there's an easy way to make this happen.

OneDrive Management
OneDrive Management
OneDrive: A Microsoft file hosting and synchronization service.Management: The act or process of organizing, handling, directing or controlling something.
1,071 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Emi Zhang-MSFT 20,106 Reputation points Microsoft Vendor
    2020-10-16T08:12:14.64+00:00

    Hi @Knox ,
    Refer to these support articles about Sync OneDrive:

    https://support.microsoft.com/en-us/office/sync-files-with-onedrive-in-windows-615391c4-2bd3-4aae-a42a-858262e42a49?ui=en-us&rs=en-us&ad=us

    https://support.microsoft.com/en-us/office/choose-which-onedrive-folders-to-sync-to-your-computer-98b8b011-8b94-419b-aa95-a14ff2415e85

    This support article is about how to fix OneDrive sync problems:

    https://support.microsoft.com/en-us/office/fix-onedrive-sync-problems-0899b115-05f7-45ec-95b2-e4cc8c4670b2

    Hope it's helpful.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Dave Patrick 426K Reputation points MVP
    2020-10-16T14:10:54.9+00:00

    Make sure the parent folder is selected here.

    32974-image.png

    --please don't forget to Accept as answer if the reply is helpful--

    0 comments No comments