(VS 2022) I am trying to use outside libraries but whenever I open an example solution, many things don't load.

esdv q 0 Reputation points

I'm not sure if this is reproducible, but I'm fairly sure it's a problem with visual studio or CMake(3.26.3). This is because the two libraries I have tried to use(FLTK 1.3.8 and glfw 3.3.8) have both yielded the same exact error when I tried to run example files in them. My own solution files I've created(vs created) work fine. I will follow online instructions to a T(most recently this one), and when it comes to click on the .sln file I get a popup and and multiple error messages in the output tab at the bottom along the lines of "C:/x/x/x/x, illegal characters in path" I don't know why I am getting this error, and I don't know how to fix it. This is on an Acer Aspire 3.

here is a video of my process.

error I get in the output window

C:\Users\ethan's shenanigans\Desktop\glfw-3.3.8\build\tests\windows.vcxproj : error  : Cannot evaluate the item metadata "%(FullPath)". The item metadata "%(FullPath)" cannot be applied to the path "@(DocFileItem->'C:\Users\ethan's shenanigans\Desktop\glfw-3.3.8\build\tests\Debug%(Filename)%(Extension)')". Illegal characters in path.  C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Current\Bin\amd64\Microsoft.Common.CurrentVersion.targets

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
3,173 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. esdv q 0 Reputation points

    figured it out, my username contained a " ' " in it and that name was in the file path.

    0 comments No comments