EDGE can not be used,my computer is WIN10

旭 范 0 Reputation points
2023-05-14T06:38:08.25+00:00

User's image

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,204 questions
Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,943 questions
{count} votes

1 answer

Sort by: Most helpful
  1. ShiJieLi-MSFT 8,266 Reputation points Microsoft Vendor
    2023-05-15T01:41:35.7966667+00:00

    Hi @旭 范,

    This is a known issue on the latest version of Microsoft Edge. Microsoft is aware of this issue and is actively investigating.

    You can try the following workarounds for now:

    1. Ensure Windows Compatibility Mode is not on (Properties --> Compatibility --> Run this program in compatibility mode for). Close all Edge instances, and make sure to use the "Details" tab in task manager to ensure that all msedge.exe processes are closed. Run Edge and see if the issue still occurs.
    2. Ensure Hardware-enforced Stack Protection is not on:

    a. During this, make sure to record any settings you create or change.

    b. Open the "Windows Security" app.

    c. Select "App & browser control".

    d. Select "Exploit protection settings".

    e. Select "Program settings".

    f. Look to see if msedge.exe is listed.

    g. If it is, select it and select "Edit".

    h. If it is not, select "Add program to customize", click "Add program by name", and then enter msedge.exe in the "Enter program name" input field.

    i. Either way, in the "Program settings: msedge.exe" dialog, locate the section labeled "Hardware-enforced Stack Protection".

    j. In this section, ensure that "Override system settings" is checked, the toggle is set to "On", the "Enforce for all modules instead of only compatible modules" is unchecked, and "Audit only" is checked.

    k. Click the "Apply" button.

    l. Close all Edge instances, making sure to use the "Details" tab in task manager to ensure that all msedge.exe processes are closed.

    m. Run Edge and confirm if the issue still occurs.

    n. If the issue does still occur, perform the previous steps but with "Override system settings" checked, and the toggle set to "Off".

    o. Close all Edge instances, making sure to use the "Details" tab in task manager to ensure that all msedge.exe processes are closed.

    p. Run Edge and confirm if the issue still occurs.

    q. If the issue does still occur, set the setting back to their original values.

    If the workarounds above don't work, you can roll back to 112. The issue does not appear to occur on Edge 112. You can consider rolling back using the enterprise rollback documentation.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Best Regards,

    Shijie Li

    0 comments No comments